Plugin error: quality-control evaluate-composition

Since I want to compare the relative taxonomic composition between mock community and Qiime2 taxa barplot result, so i convert the expected and observed tax relative composition (%) table to biom file, then import to qiime2 as qza file using following commands.
biom convert -i Qiime2_PE_L2.txt -o Qiime2_PE_L2_tax_hdf5.biom --table-type="Taxon table" --to-hdf5
Expect_L4_tax_hdf5_biom.qza (4.8 KB)
Qiime2_PE_L4.txt (46.8 KB)
Qiime1_L4_tax_hdf5_biom.qza (36.8 KB)

Then i ran evaluate-composition plugin and got following errors

Plugin error from quality-control:

Requested level of 5 is larger than the maximum level available in taxonomy data (4).

Debug info has been saved to /tmp/qiime2-q2cli-err-4ofg001j.log
(qiime2-2017.12) [email protected]:~/scratch/Shannon/Benchmark$ more /tmp/qiime2-q2cli-err-4ofg001j.log
Traceback (most recent call last):
File "/opt/apps/Miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/q2cli/commands.py", line 224, in call
results = action(**arguments)
File "", line 2, in evaluate_composition
File "/opt/apps/Miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/qiime2/sdk/action.py", line 228, in bound_callable
output_types, provenance)
File "/opt/apps/Miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/qiime2/sdk/action.py", line 424, in callable_executor
ret_val = self._callable(output_dir=temp_dir, **view_args)
File "/opt/apps/Miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/q2_quality_control/quality_control.py", line 69, in evaluate_composition
plot_observed_features_ratio=plot_observed_features_ratio)
File "/opt/apps/Miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/q2_quality_control/_utilities.py", line 96, in _evaluate_composition
results, vectors = _compute_per_level_accuracy(exp, obs, metadata, depth)
File "/opt/apps/Miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/q2_quality_control/_utilities.py", line 153, in _compute_per_level_accuracy
exp_collapsed = _collapse_table(exp, level)
File "/opt/apps/Miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/q2_quality_control/_utilities.py", line 291, in _collapse_table
table.columns, index=table.columns, name='Taxon'), level)
File "/opt/apps/Miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/q2_taxa/_method.py", line 27, in collapse
(level, max_observed_level))
ValueError: Requested level of 5 is larger than the maximum level available in taxonomy data (4).

Would anyone help me to find where i went wrong?
thanks
Gary
qiime tools import --input-path Qiime2_PE_L4_tax_hdf5.biom --type 'FeatureTable[RelativeFrequency]' --source-format BIOMV210Format --output-path Qiime2_PE_L4_tax_hdf5_biom.qza

Absolutely :smile:

Looks like you have collapsed your taxonomy to 4 levels. evaluate-composition expects 7 levels by default (I should probably just make this a required parameter, rather than setting a default :disappointed:). Set the --p-depth parameter to 4 and everything should be okay :relieved:

I hope that helps!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.