Plugin error from moshpit

Dear Q2 devs,

I would like to report one error from the moshpit plugin.
First of all, I run the same command in three versions of qiime2.

Command:

mkdir -p TEMP
export TMPDIR=TEMP

qiime moshpit classify-kraken2 \
     --i-seqs demux.qza \
     --i-kraken2-db kraken2_database.qza \
     --p-threads 12 \
     --p-confidence 0.51 \
     --p-minimum-base-quality 20 \
     --output-dir Taxonomy \
     --p-report-minimizer-data

Vesion1: qiime2-shotgun-2023.9
Results: It worked!

Vesrion2: qiime2-shotgun-2024.2
Results: Error

Version3: qiime2-metagenome-2024.5
Results: Error

Error from versions 2 and 3:

Plugin error from moshpit (it is a list of similar messages, first one is provided here):

[('/WS/TEMP/batch1-50/qiime2/data/088c12e6-2f7b-4bdf-a37c-6f1cd1c36516/data/Co_195.report.txt', '/WS/TEMP/batch1-50/qiime2/processes/18210-1719214914.08@user_name/ad30702a-11e2-432a-9ae3-f9a6e113da51.6664663481188062162/ad30702a-11e2-432a-9ae3-f9a6e113da51/data/Co_195.report.txt', "[Errno 1] Operation not permitted: '/WS/TEMP/batch1-50/qiime2/data/088c12e6-2f7b-4bdf-a37c-6f1cd1c36516/data/Co_195.report.txt' -> '/WS/TEMP/batch1-50/qiime2/processes/18210-1719214914.08@user_name/ad30702a-11e2-432a-9ae3-f9a6e113da51.6664663481188062162/ad30702a-11e2-432a-9ae3-f9a6e113da51/data/Co_195.report.txt'"), ]

I am working on the cluster with restricted temp to 256 Gb storage (separate fast drive), so I export TEMP to a larger (slower) drive.
I assumed that the error in versions 2 and 3 is caused be me exporting temp directory, so I divided my dataset into batches and run it without exporting TEMP. It worked.

I am curious now why exporting TEMP directory worked for me with qiime2-shotgun-2023.9, but caused an error in versions 2024.2 and 2024.5.

1 Like