Plugin error from itsxpress: fastq.gz is not a(n) FastqGzFormat file and Missing sequence for record beginning on line 13


I got an error when I was trying to Trimming ITS samples:
qiime itsxpress trim-pair-output-unmerged
–i-per-sample-sequences demux_trimmed.qza
–p-region ITS1
–p-taxa F
–p-threads 16
–o-trimmed itsxpress_trimmed.qza

Plugin error from itsxpress:
/export2/home/yluo/temp/q2-CasavaOneEightSingleLanePerSampleDirFmt-91msip6l/LUO.65_ATGCCGTA_L001_R1_001.fastq.gz is not a(n) FastqGzFormat file:
Missing sequence for record beginning on line 13

I uninstall the conda version of ITSxpress, and install again,then rerun. It gave the same error.
The thing is that it ran successfully for my first batch of ITS samples, however it failed for me second batch of ITS samples, though the same script was used.

Does someone have any suggestions?
Thanks in advance!
Best regards,Yujia


Welcome to the forum, @Yujia!
A quick search :mag: shows that Missing sequence for record beginning on line 13 is an error message that pops up with some frequency. Here are two posts that cover the issue:

The first one suggests you make sure your version of itsexpress is up-to-date (at least version 1.7.2). It sounds like you’ve tried to do that, but it’s worth checking exactly what version you have before moving on. 1.7.2 should fix this problem for you.

If that doesn’t work, the second tackles the problem head-on, finding and removing empty/corrupt reads in your data. This approach seems to work (in a pinch), but treats the symptoms rather than curing the problem (a fixed bug in itsexpress), and may take more time/energy if the error is widespread.

Hope this helps,
Chris :raccoon:


Hi Chris,
Thanks! itsxpress does have the updated version. So I will try the second suggestion :slight_smile:
I will let you know soon!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.