Plugin error from feature-classifier with virtualbox

Good afternoon,
I am attempting to run qiime feature-classifier on my windows computer using virtualbox. Everything seems to run fine until I reach this step’ qiime feature-classifier classify-sklearn’, where I receive a repeated error that says ’ Unable to allocate array with shape (895606784) and data type float64. Attached is a picture of the error log.

Hi there @11121! Can you please re-run the command with the addition of the --verbose flag? I suspect you are running out of memory…

Hello there
I had the same error as mentioned above. I added --verbose and got this error box below. The error message was not inside the terminal but appeared as an error box saying

Host system reported disk full. VM execution is suspended. You can resume after freeing some space.

Error ID: DevATA_DISKFULL
Severity: Non-Fatal Error

Well I saw that my hard drive had only few hundred MBs left. I cleaned it to have 50GB free space and ran again. Still I got this error message. If the memory message mean here RAM memory then I am using 16GB ram out of which 10 GB is dedicated to VM.
Please advise

qiime feature-classifier classify-sklearn
–i-classifier silva-132-99-nb-classifier.qza
–i-reads rep-seqs-healthy-single.qza
–o-classification 13K-core-metrics-results/taxonomy.qza
–verbose

Hello again
Surprisingly, As I tried to download a research article in my computer, it failed saying Disk full. I went to my computer and saw that it is again red and have zero MB space. As I told earlier, minuts ago I delected 50 GB trash data.
Is there something wrong with this command or what happened to my computer I don’t know.

@drmusk,
Sounds like your main issues are hardware/disk space and we cannot help you there, that is not related to QIIME 2.

But the error you are seeing with QIIME 2 is indeed a memory error, and quite typical — you are running with 10GB dedicated space on a VM, which is just not enough for classification with SILVA.

Switch to a smaller database (like greengenes) or search the forum for other troubleshooting examples of similar cases… there’s lots of advice out there for resolving the memory error.

Good luck!

1 Like