Plugin error from empress

Plugin error from empress:

‘Emperor’ object has no attribute ‘render_base_dependencies’

Hi everyone! I am getting this error message when I am trying to use empress plugin funciton community-plot for an empire plot. I am confident there is nothing wrong with my input because I tried running the commands from the empress tutorial and the same error popped up. Could there be some issue with my qiime in my conda environment? If so, what could it be?

Hi @Jeffrey_Chiu,

That’s an interesting error. I suspect the problem may be your Emperor version being incompatible with Empress; the render_base_dependencies Emperor method was just added in September 2020—so from this error message it looks like the version of Emperor you have installed in your QIIME 2 conda environment isn’t compatible with Empress. As of writing, the latest version of Empress needs an Emperor version of at least 1.0.2.

I think one of the two following options should fix this problem:

  1. Install a recent version of QIIME 2 (e.g. 2021.2), and then install Empress into this new environment. This should automatically install a compatible version of Emperor into this new environment.

  2. Within your current QIIME 2 environment, run pip install --upgrade emperor to try to update Emperor (this may break other things in your QIIME 2 environment if it is a very old environment).

If neither option works, let me know and we can try to debug further!

I’m also cc’ing @yoshiki who is probs the most qualified person to help debug this :slight_smile:

4 Likes

Hey @fedarko ! Gave the second option a try and it worked. Went from emperor 1.0.2 to emperor 1.0.3. Thanks a ton!

1 Like

Awesome, glad that worked out!

It is strange that your environment already had Emperor 1.0.2 installed—that version of Emperor should have also worked with Empress. Maybe something went wrong in the initial environment setup? In any case, now that the error is fixed, it should be okay.

1 Like