Plugin error from emperor: At least one eigval must be present.

Hello,

I run this piece of code,

qiime emperor biplot
–i-biplot resultsPathwayTable50/biplotPathwayTable50.qza
–m-sample-metadata-file metadata_songbird.txt
–p-ignore-missing-samples
–p-number-of-features 7
–o-visualization resultsPathwayTable50/emperorBiplotPathwayTable50.qzv

Plugin error from the emperor:

None of the sample identifiers match between the metadata and the coordinates. Verify that you are using metadata and coordinates corresponding to the same dataset.

To check so, I ran
qiime feature-table summarize
–i-table pathwayTable50.qza
–o-visualization pathwayTable50.qzv

The sample IDs did match between the feature input table and the metadata.

Could you tell me why does it still show as such?

Best,
Promi.

Hi Promi,

Is the biplot you’re using from mmvec? The biplots mmvec produces are a bit unusual – points in the biplot (“samples”) are metabolites, not actual samples. This can complicate things when visualizing the biplots in Emperor. See below for some more details (copy-and-pasted from @Mehrbod_Estaki’s Q-Tips FAQs :slight_smile: )

Q: A user was getting the following error when running Emperor on the biplot created by mmvec: “None of the sample identifiers match between the metadata and the coordinates. Verify that you are using metadata and coordinates corresponding to the same dataset.”

A: The problem was that the points (samples) used in the mmvec biplot don’t correspond to actual samples: they instead correspond to metabolites. The problem was solved by making a “fake” metadata file where the sample IDs were metabolite names, and using that as the input “sample metadata file” for Emperor. (In practice this “fake” file should be replaced with a more detailed metadata file that actually describes the metabolites – from GNPS, for example.)

For future reference, if you’re unsure about how your biplot is formatted – you can always unzip the biplot QZA file and look in the underlying data/ordination.txt file to see what IDs are being used as the samples (“site”) or features (“species”).

Let us know if this helps! If not, we can try to figure out where to go from here – as mentioned above, you should be able to unzip the biplotPathwayTable50.qza artifact and check to see what IDs are being used as samples, and I think this should point you to the source of the problem.

1 Like

Hi Marcus,

The biplot was generated from Songbird. I could visualize the differentials in Qurro but not the biplots in emperor.

I did unzip the .qza file and could see the columns as “species” and pathway names as “site”. Except with an extra addition of “T.” to my column categories as attached.

ordination.txt (164.2 KB)

Thanks for letting me know! Ok, gotcha. So, since the “sites” in this ordination describe pathway names, Emperor is expecting your sample metadata to describe these pathways – this is confusing because the pathways aren’t actually “samples”, but Emperor’s code doesn’t know that.

If you have a “feature metadata” tab-separated file describing these pathways, you should be able to pass that to the qiime emperor biplot command as the --m-sample-metadata-file parameter. I think this should fix the problem. (If you don’t have a feature metadata file lying around, it should be possible to create a “fake” one for the purpose of visualization by making a simple TSV file where the row names are pathway names. You might need to add an extra bogus column to the file in order to make QIIME 2 treat it as a valid metadata file. This should be doable in python or something without a lot of work – let me know if you would like help with this.)

Hopefully this helps!

I tried as you suggested and it worked without an error. But, the visualization file shows opposite of how I expected it to be, with pathways as dots and arrows as group. I wanted a plot where the dots represent samples and arrows as pathway names. Can you suggest what am I missing to achieve this?

I don’t think there’s a way to get an ordinary biplot (where the points really are samples) from Songbird. However, at least within the QIIME 2 ecosystem, I know you should be able to get that sort of biplot from DEICODE – I’d suggest trying that out.

1 Like

Thanks for the suggestion Marcus :slight_smile: