Plugin error from diversity [Errno 2]

I have a problem with Alpha rarefaction plotting, here is an error code.
this is my code input

qiime diversity alpha-rarefaction
--i-table table_TA_bacteria_dada2.qza
--i-phylogeny rooted_tree_TA_bacteria.qza
--p-max-depth 1360
--m-metadata-file TA_bateria_metadata.txt
--o-visualization TA_bacteria_alpha-rarefaction.qzv

and the error sign was showed

Plugin error from diversity:

[Errno 2] No such file or directory: '/tmp/qiime2-temp-lahqhp2j/observed_otus-Loading%28kg/m3%3Fday%29.jsonp'

Debug info has been saved to /tmp/qiime2-q2cli-err-t4id7poi.log

rooted_tree_TA_bacteria.qza is genernated from

qiime phylogeny align-to-tree-mafft-fasttree
--i-sequences TA_bacteria_dada2.qza
--o-alignment aligned_TA_bacteria_dada2.qza
--o-masked-alignment masked_aligned_TA_bacteria_dada2.qza
--o-tree unrooted_tree_TA_bacteria.qza
--o-rooted-tree rooted_tree_TA_bacteria.qza

table_TA_bacteria_dada2.qza and TA_bateria_metadata.txt is worked in the following command

#bar plot
qiime taxa barplot
--i-table table_TA_bacteria_dada2.qza
--i-taxonomy TA_bacteria_taxonomy.qza
--m-metadata-file TA_bateria_metadata.txt
--o-visualization taxa_bar_plots_TA_bacteria.qzv

and all the file are in the same folder

Could someone help me?
Thanks in advance.


1 Like

Welcome to the forum @chaojui!

It looks like you’ve run into a known issue with using forward slashes (and other special characters) as metadata column names. You can find a few examples of this (with detailed solutions) by searching the forum archives:

Remove the forward slashes and you should be good to go.

Good luck!

1 Like

Thanks to @Nicholas_Bokulich

My problem is solved and there is feedback for people who are also facing this.
At first, I don’t really understand the solution (maybe I didn’t read the previous topic clearly and I think the problem is the slash in the command line but actually the problem is in metadata)
So donot put any slash (/) in metadata file and this step would work well
:grinning: :grinning: :grinning:


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.