Plugin error from demux-12 nt barcodes

Hello Hope all is well. I have a running issue during the demux step. I always use certain kind of 10nt barcodes. But I keep getting this error this time

Plugin error from demux:

Golay decoding requires 12nt barcodes. The barcode attempting to be decoded (CGTGCTGTCA) is of length 10nt.

Debug info has been saved to /tmp/qiime2-q2cli-err-6_kivbhs.log

Would you please let me know what should I do?

Thank yo,
MZ

Hi @zeineldn,
It sounds like you are using the demux emp method but are not actually using EMP-protocol barcodes.

Check out the help documentation for that method: you can use the --p-no-golay-error-correction option to use other barcoding schemes.

Good luck!

Perfect. Thank you. I will try that.

Appreciate your help!

1 Like