Plugin error from DADA2 (return code 1)

Hello it's me again, I was working with the command " qiime dada2 denoised paired" and this is the arguments that I wrote
qiime dada2 denoise-paired --i-demultiplexed-seqs raw-reads.qza --p-trunc-len-f 173 --p-trunc-len-r 73 --p-trim-left-f 23 --p-trim-left-r 23 --p-max-ee-f 2.0 --p-max-ee-r 2.0 --p-trunc-q 2 --p-min-overlap 12 --p-pooling-method 'independent' --p-chimera-method 'consensus' --p-min-fold-parent-over-abundance 1.0 --p-n-threads 1 --p-n-reads-learn 1000000 --o-table FeatureTable[Frequency] --o-representative-sequences FeatureData[Sequence] --o-denoising-stats SampleData[DADA2Stats]

But, when qiime finished to run, the terminal gaven an error

I’m really new user to qiime2 and don’t know much about the program, I hope that you can help me again.

Thanks :slight_smile:

Hello again Vicky :wave:

Can you post the debug info .log file that was saved into /tmp/? It should include clues about what went wrong!

is this?

Uploading: image.png...


file:///tmp/qiime2-q2cli-err-qop15zme.log

Thanks :slight_smile:

@Vicky_Rodriguez,
Hey Vicky, I think you are running into the same problem as in this post. I would start by increasing your truncation length, particularly with your reverse sequences. If you reverse read quality is super low, it might be worth working only with the forward reads, though I am not sure if this is why you have set your reverse read truncation to 73 or not.

DADA2 needs your reads to be long enough to overlap for paired in end reads, so if you cut them so short that they do not, it cannot try to pair them, which prevents addition denoising and chimeric detection steps from occurring.

Truncation occurs at the end(the 3') of the read, setting an absolute limit to how long DADA2 will let the read be. Trimming occurs at the beginning(5') of the read.

Here are some videos from a workshop, that describe the denoising process and things you should consider when setting your parameters: lecture, tutorial.

2 Likes

I had a mistake in the parameter " trun-len-r", I wrote 73 instead of 173. After checking the tutorials I changed my parameters and the problem was resolved, thank you very much :slight_smile:

3 Likes