Plugin error from dada2: [Errno 2] No such file or directory

Hello everyone, I am running DADA2 using a sequence downloaded from public source with the command;
qiime dada2 denoise-paired
--i-demultiplexed-seqs paired-end-demux.qza
--p-trunc-len-f 180
--p-trim-left-f 0
--p-trunc-len-r 160
--p-trim-left-r 0
--o-representative-sequences rep-seqs.qza
--o-table table.qza
--o-denoising-stats stats.qza
But I got the following error
Traceback (most recent call last):
File "/home/sauban/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/q2cli/", line 339, in call
results = action(**arguments)
File "", line 2, in denoise_paired
File "/home/sauban/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/qiime2/sdk/", line 210, in bound_callable
provenance.add_input(name, artifact)
File "/home/sauban/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/qiime2/core/archive/", line 425, in add_input
self.inputs[name] = self.add_ancestor(input)
File "/home/sauban/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/qiime2/core/archive/", line 167, in add_ancestor
File "/home/sauban/anaconda3/envs/qiime2-2022.8/lib/python3.8/", line 555, in copytree
with os.scandir(src) as itr:
FileNotFoundError: [Errno 2] No such file or directory: '/tmp/qiime2/sauban/data/19ed4def-edd0-4a34-ba96-bafc3a75e4c9/provenance'

Plugin error from dada2:

[Errno 2] No such file or directory: '/tmp/qiime2/sauban/data/19ed4def-edd0-4a34-ba96-bafc3a75e4c9/provenance'

See above for debug info.
How can I fix it please?

Hi @Zango,

First, I would check file names. White spaces can cause errors. I think it is better to use another character like underscore instead of white spaces. So, your file names could be demultiplexed_seqs_paired_end_demux.qza, representative_sequences_rep_seqs.qza, table_table.qza and denoising_stats_stats.qza

In addition, is it possible that you are not in the directory where demultiplexed-seqs paired-end-demux.qza is located when you run qiime dada2 denoise-paired? It seems like if you were extracted the qza file and you were located inside the provenance subfolder. This information is useful for checkings but you have to pass the .qza file to qiime dada2 denoise-paired, so maybe you have to go back some directories and run this command. A structured organization of your directories to save inputs, intermediate files and outputs will help you a lot. I wouldn't save the dada2 results inside another qiime2 artifact.

Hope it helps,


1 Like

Hello @andresarroyo,

Whitespaces in filenames are not the problem: --i-demultiplexed-seqs is the command line option and so should be separated by a space from paired-end-demux.qza, which is the demux file and does not contain whitespaces.

The file not found error does not refer to the demux artifact, but to a provenance directory which you can see on this line of the error message:

[Errno 2] No such file or directory: '/tmp/qiime2/sauban/data/19ed4def-edd0-4a34-ba96-bafc3a75e4c9/provenance'

1 Like

Hello @Zango,

This error could have happened because the unzipped artifact was deleted while the process was running. Have you tried running this command again since the first time it failed? Is it possible you are running out of space in your /tmp directory?

Thanks for the reply, but I don't think is directory issue because the file is inside the same folder I am working with

Thank you sir, I don't know about the unzipped artifact been deleted, and the available space is enough I think for the execution of the analysis

Hello @Zango,

Have you tried running this command again in case it was a fleeting issue?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.