Plugin error from clawback: taxonomy_classification does not match reference_taxonomy

Hello All,
I am trying to use clawback to assemble weights for human stool using the newest version of GTDB: r95. (The ready2wear weights uses GTDB_89).
I have modified the code found in the Ready2wear Github script: assemble-weights.gtdb.sh to generate the weights.

Every time I try to generate weights I run into this error: Plugin error from clawback: taxonomy_classification does not match reference_taxonomy

This error seems to be saying the classifier I built used a different reference taxonomy then I am passing to clawback. I have made sure that my classifier was built using the same reference seqs, and taxonomy. My code below shows that the same reference taxonomy and reference reads are used to make my classifier.

I am running QIIME 2-2021.4.
The code:

    qiime feature-classifier fit-classifier-naive-bayes \
  --i-reference-reads ~/chloe-analysis/Endo/vaginalrectaldata/GTDB/bac120_ssu_reps_r95.qza \
  --i-reference-taxonomy ~/chloe-analysis/Endo/vaginalrectaldata/GTDB/bac120_taxonomy_r95.qza  \
  --o-classifier gtdb-r95-classifier.qza

qiime feature-classifier classify-sklearn  \
--i-classifier gtdb-r95-classifier.qza \
--i-reads sv.qza \
--p-n-jobs -1  \
--o-classification classification.qza

qiime clawback generate-class-weights \
 --i-reference-taxonomy  ~/chloe-analysis/Endo/vaginalrectaldata/GTDB/bac120_taxonomy_r95.qza  \
 --i-reference-sequences ~/chloe-analysis/Endo/vaginalrectaldata/GTDB/bac120_ssu_reps_r95.qza  \
 --i-samples samples.qza \
 --i-taxonomy-classification classification.qza \
 --o-class-weight human-stool-weight.qza

Any help would be greatly appreciated
Thank you!

Hi @cherman2 ,
I think the issue is that you are not disabling the confidence parameter in this command:

compare that to the example in readytowear:

(Note: The readytowear example is old and the classify-sklearn API has since changed, so line 62 should instead be --p-confidence=disable)

Give that a try and let me know what you find!

:qiime2:

Prof Bok to the rescue! That solved my issue.
Thank you so much.

4 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.