Plugin error for feature classifier

Hi
I have encountered an error when assigning taxonomy to my samples using qiime feature-classifier classify-sklearn command. (Using Mac under Miniconda environment with Qiime2.2019.4)
"Error:QIIME 2 has no plugin/command named ‘feature-classifier’
So I tried to run the “Training feature classifiers tutorial” (https://docs.qiime2.org/2019.4/tutorials/feature-classifier/) and encountered the same error when I ran the “Extract reference reads” part
qiime feature-classifier extract-reads
–i-sequences 85_otus.qza
–p-f-primer GTGCCAGCMGCCGCGGTAA
–p-r-primer GGACTACHVGGGTWTCTAAT
–p-trunc-len 120
–p-min-length 100
–p-max-length 400
–o-reads ref-seqs.qza

I’ve got the same error in both mac and virtualbox qiime2 environment. Is there a way to manually install the feature classifier plugin?
Thank you so much for your help

Welcome to the forum, @SP2019!
It is possible to install q2-feature-classifier independently, but it might be worth doing a little troubleshooting first.

First, I might use conda list to check whether q2-feature-classifiers is already installed. If it’s present in your active environment, but not being recognized by the command line, it could be a typo, or something more worrisome.

Second, it might also be worth doing a fresh install. That way conda can ensure everything you need is present, rather than trying to piecemeal fill holes. I mention this, because a clean install should include feature-classifier, and if it doesn’t, I wonder what else could be missing.

Let us know what you learn, ok? Good luck out there!
Chris

Hi ChrisKeefe
Thank you so much for your suggestions. I did reinstall miniconda and qiime2, and the feature classifier appeared. ThoFeature classifier troubleshoot.txt (41.3 KB) ugh, after installing the scikit-learn=0.19.1 (conda install --override-channels -c defaults scikit-learn=0.19.1) the feature classifier disappeared. As I'm going to use the silva-132-99-nb-classifier.qza, which is trained using scikit-learn 0.19.1. Is there any workaround?
Thanks

1 Like

Download the latest pre-trained classifier (or re-train your own). That’s the best way to ensure your installed version of scikit-learn matches the version used to train the classifier.

Yep, because it depends on a later version of scikit-learn, so conda removes it if you force install the earlier version. There should be a warning that appears, mentioning the packages that will be downgraded/uninstalled

1 Like

Great! Thanks! I’ve downloaded the latest pre-tained classifier from the Qiime2 data resources page, and seems running now.
Thank you so much for your help and have a nice day

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.