packages not found error on Mac

Hi all,
I am experiencing installing problem with qiime2 -2024.2
I have tried multiple times reinstalling and still not being able to install in properly:

Preparing transaction: done
Verifying transaction: done
Executing transaction: done
(qiime2-core-2024.2) cz@shihuize-de-MacBook-Pro ~ % qiime2 --help
zsh: command not found: qiime2

Please give me some hints, thank you so much!!

Welcome to the forum!

I am always doing this error as well!

It should be:

qiime --help

2 Likes

thanks!!
but it's still the same...:frowning:

Did you run it in the activated qiime2 environment?
Could you share the screenshot with the command and error?

I think I did successfully activate the environment but somehow it kept showing qiime not found
However, when I connected the environment to PyCharm, it worked fine! so...does it mean that I have the right environment now??
Thank you

Hi!
I am not sure at all about pycharm and why it works only after that. I guess, something bounded to your installation process. However, if you managed to get it working... Just go ahead with analyses and let's hope that it will work further.

Best,

1 Like