Package conflicts when installing qiime2 2021.4

I'm installing qiime 2 2021.4 on a server (centos 7.8.x) with conda version 4.7.12 and get incompatible package errors.

$ conda env create -n qiime2-2021.4 --file qiime2-2021.4-py38-linux-conda.yml
...
UnsatisfiableError: The following specifications were found to be incompatible w
ith each other:

Package tbb conflicts for:
q2-deblur=2021.4.0 -> numpy -> libblas[version='>=3.8.0,<4.0a0'] -> mkl[version=
'>=2019.0,<2020.0a0'] -> tbb=2021
q2-alignment=2021.4.0 -> q2-types=2021.4 -> blas=[build=openblas] -> libblas==3.
8.0=13_openblas -> mkl[version='>=2019.0,<2020.0a0'] -> tbb=2021
numpy=1.20.2 -> mkl[version='>=2021.2.0,<2022.0a0'] -> tbb=2021
r-rprojroot=2.0.2 -> r-base[version='>=3.6,<3.7.0a0'] -> libblas[version='>=3.8.0,<4.0a0'] -> mkl[version='>=2019.0,<2020.0a0'] -> tbb=2021
seaborn-base=0.11.1 -> numpy[version='>=1.15'] -> mkl[version='>=2021.2.0,<2022.0a0'] -> tbb=2021
r-bh=1.75.0_0 -> r-base[version='>=4.0,<4.1.0a0'] -> libblas[version='>=3.8.0,<4.0a0'] -> mkl[version='>=2019.0,<2020.0a0'] -> tbb=2021
r-isoband=0.2.4 -> r-base[version='>=4.1,<4.2.0a0'] -> libblas[version='>=3.8.0,<4.0a0'] -> mkl[version='>=2019.0,<2020.0a0'] -> tbb=2021
r-base=4.0.3 -> libblas[version='>=3.8.0,<4.0a0'] -> mkl[version='>=2019.0,<2020.0a0'] -> tbb=2021
r-ps=1.6.0 -> r-base[version='>=4.1,<4.2.0a0'] -> libblas[version='>=3.8.0,<4.0a0'] -> mkl[version='>=2019.0,<2020.0a0'] -> tbb=2021

The issue is similar to the one described here and I think updating conda may help to resolve the conflicts but conda can't yet be updated on the server due to others internal issues. Qiime 2 2021.2 can be installed properly on the same server with conda version 4.7.12 and I was wondering if you have a solution to avoid the conflicts (something like replacing or relaxing the some package/versions in the conda env yaml) ?

Hi @mandiayba - are you able to update your installation of conda? That's the first step when following the QIIME 2 installation guide. That version of conda is almost 2 years old, and a lot has changed in that time.

Keep us posted! :qiime2:

1 Like

Hi @thermokarst thank you for your answer. We can't update conda for the moment it's why I was asking if you have solution to install on conda 4.7. We finally decided to use qiime2 2021.2 that works fine while waiting to update conda