OTU-related error

Hi everybody, I wish to get a help in the following issue.
I was trying to run the following command

qiime tools import
--type 'FeatureData[Sequence]'
--input-path /mnt/c/samples/ezbiocloud_qiime_full.fasta
--output-path 99_otus_16S

Then, I got the error {'/mnt/c/samples/ezbiocloud_qiime_full.fasta' does not exist}.

I wish you help me. Thanks in advance!!



It looks like QIIME 2 is having trouble finding your file: ezbiocloud_qiime_full.fasta.

First step is that we should make sure that your file exists and that it is located where you think it is:

> ls /mnt/c/samples/ezbiocloud_qiime_full.fasta

If your terminal is able to find your file in that location, it will simply echo back /mnt/c/samples/ezbiocloud_qiime_full.fasta, If it is unable to locate it, it will give you a message that there is no such file or directory. If it can't find it, you will have to figure out where it is:

> locate ezbiocloud_qiime_full.fasta

Then you can either specify the full path to that location or you can change to the directory(folder) that contains it and run your command there using just the filename:

qiime tools import \
--type 'FeatureData[Sequence]' \
--input-path ezbiocloud_qiime_full.fasta \
--output-path ezbiocloud.qza

You also will want to add .qza to the end of your output, as it will be a QIIME 2 Artifact. You can see this in the example above, though feel free to call it whatever you want :slightly_smiling_face:

Hope this helps!

Thank you so much. I do appreciate your consideration and kindness. Locating the ezbiocloud worked well, and the problem is solved.
Thanks again
Have a great weekend!!!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.