not QIIME2 Artifact problem and No module name problem (after checking validate)

Hello

In the QIIME2 forum, I can't find a solution to the same problem as me, so I leave a post. Sorry if I missed it.

I have been having the following problem a few days ago.

Following the Tutorial, QIIME2 analysis is in progress.
I've seen an error message several times saying it's not QIIME2 Artifact.

I looked for the following issues and tried setting TMPDIR, but it didn't work.

After checking Validate, the following error occurs.

The only way I found was to delete QIIME2 and reinstall it, then continue the step.
However, it is too difficult to analyze because it needs to be reinstalled 2-3 times for one analysis.
Please let me know if there is a way to solve this problem

I have attached some of my information.
4_storage

If you know the solution
Please let me know.

Thank you for your help, I am a bit of a coding and command language noob (!)

YeonGyun Jung

How are you reinstalling (or just installing in the first place?)

Some of the screenshots you shared look like you might have an "incomplete" installation, which could certainly cause problems. I have never heard of anyone needing to reinstall so often, so I suspect something is fundamentally wrong here.

Personally, I would start with removing your conda environment with QIIME 2 in it, clearing the conda cache, and then reinstalling:

conda env remove -n qiime2-2020.2
conda clean --all

Let's start with that and see how it goes - keep us posted!

:qiime2:

I deleted QIIME2 using the command you gave me.

conda env remove -n qiime2-2020.2
conda clean --all

It was re-installed using the following command.

wget https://data.qiime2.org/distro/core/qiime2-2020.2-py36-linux-conda.yml
conda env create -n qiime2-2020.2 --file qiime2-2020.2-py36-linux-conda.yml

But I still get the same error.

The only workaround I found was to clear Anaconda (or Miniconda), install a new Anaconda and install QIIME2 again.
It works fine at first, but after a few commands, the error occurs again.
(I followed Amplicon SOP v2 (qiime2 2020.2) · LangilleLab/microbiome_helper Wiki · GitHub)

I analyze using the Linux server provided by the lab.
(Use the ID provided.)

Could it be a problem with the Linux Server?

According to the server administrator, it is not a server problem because a new environment is provided for each ID.
However, I still have a recurring error and I still don't know how to fix it.

If there is a solution please let me know :frowning:

Thank you for your help

YeonGyun Jung

That actually sounds like a huge red flag to me - the error you shared above indicates that the environment is suddenly missing files if your sysadmin has some manual process of creating new environments on the fly, its possible that this system isn’t completely replicating the environment. Chat with your sysadmin about this to learn more about how they have structured this system.