no such option: --parttree

Hi there!

I ran ‘qiime phylogeny align-to-tree-mafft-fasttree --i-sequences feature-rep-seq.qza --o-alignment aligned-rep-seqs.qza --o-masked-alignment masked-alignment-rep-seqs.qza --o-tree unrooted-tree.qza --verbose --o-rooted-tree rooted-tree.qza’ and got the following Plugin Error:

Plugin error from phylogeny:

The number of sequences in your feature table is larger than 1 million, please use the parttree parameter

I have tried the same command with the flag --parttree and --p-parttree which resulted in a ‘no such option’-error. Since I could not find any other way of using the parttree parameter in the Forum, I now wonder if I overlooked something??
(P.S. I am using qiime2 version 2019.4.0)


Hi @evus,
That is an option in the qiime alignment mafft method, which is where that error is coming from.

So unfortunately I think you will need to run the individual methods separately in QIIME 2, instead of using this pipeline, which is really just a convenience method to perform 4 steps in one. So you would use these commands to replicate, and in doing so have a little more control over the parameter settings for each method:

  1. qiime alignment mafft
  2. qiime alignment mask
  3. qiime phylogeny fasttree
  4. qiime phylogeny midpoint-root

I have opened a feature request to add this in a future release of QIIME 2.

Good luck!


Thanks @Nicholas_Bokulich,

running the individual pipeline methods separately worked out. I also found a nice qiime community tutorial on the steps of the align-to-tree-mafft-fasttree pipeline, in case someone else encounters the same issue: Q2-phylogeny: Community Tutorial

Hi @evus, the latest version of that tutorial can be found here: