No sequences were mapped to samples.

Hi all,

I am currently running the following command:
qiime demux emp-single
--m-barcodes-column 'BarcodeSequence'

And was given the following error message:
Plugin error from demux:

No sequences were mapped to samples. Check that your barcodes are in the correct orientation (see the rev_comp_barcodes and/or rev_comp_mapping_barcodes options). If barcodes are NOT Golay format set golay_error_correction to False.

I have received this message before but it was a few years ago and I can't figure out what I did to fix it. I tried utilizing the -p-no-golay-error-correction to no avail. Does anyone know what a potential fix is? I did experience an issue with the sequencing run where there was no Index file generated, but after speaking with Illumina, I fixed this issue and re-ran the analysis to receive the Index file on the Local Run Manager.

Any help would be super appreciated.

Hi @ThatGuySam,

If you read the help text via qiime demux emp-single --help you'll see that there are two optional parameters you can make use of: --p-rev-comp-barcodes and --p-rev-comp-mapping-barcodes. You might want to try using one or both of these flags.

Hi Mike,

Apologies for leaving out all of the info in the first post, I tried to be thorough but forgot. Other tutorials that I read on here stated that because this is an Illumina MiSeq library, the barcodes are forward read and the -p-rev-comp commands should be removed from the command system. Neither of these commands do not work for me when I try the code with them included.

This may not always be the case. Sometimes it has to do with how the barcodes are entered in your barcodes file. Sometimes they are reverse complemented.

Hmm... I'm not sure what the issue would be. :man_shrugging:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.