No disk space left when using Docker

Hi, I am a high school sophomore, and I recently started using QIIME2 as part of a research project.

I have been having the same problem when running Deblur and DADA2. I am running the following command:

‘qiime quality-filter q-score --i-demux demux-samp1.qza --o-filtered-sequences demuxsamp1-filtered.qza --o-filter-stats demuxsamp1-filter-stats.qza &’

(Note: I have downloaded QIIME on VirtualBox (Docker Terminal) and I have an 8GB RAM with 512GB storage and 265GB available.)

I have attempted to change the /tmp directory with the following command:


echo $TMPDIR

…but that does not work.

I have also tried ‘docker images prune’ and ‘docker container prune’ in the Docker command-line prompt, but that does not seem to have worked either.

I would greatly appreciate some guidance.

Thank you.

Hi @is-kal4! Can we get a bit more information in order to better assist you?

We have a few follow-up questions, but they will depend on your answers above related to your specific setup. Thanks! :t_rex:

Hi @thermokarst,

I am running QIIME2 version 2017.10.0, and I am running the official docker image on Docker Toolbox for Windows.

Thank you.

Thanks for the info @is-kal4! Docker Toolbox is a bit of a pain (and it is a legacy solution - I wouldn't be surprised if it is discontinued in the near future), since it runs Docker inside of a VirtualBox VM, instead of running Docker natively. In my opinion you would be better off using the QIIME 2 VirtualBox Image - since this will be less overhead on your computer (then you would only be running one form of virtualization, instead of two). If you choose to stick with your current arrangement, there isn't too much help we can provide specifically about resizing your Docker Toolbox VM, but a quick Google Search :tm: yield this:

Keep us posted! :t_rex:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.