Multiple errors with conda install of qiime2

Hi

I am following the conda install instructions for qiime2 on Linux, and there are multiple problems.

First we have:

Error: No packages found in current linux-64 channels matching: intel-openmp 2018.0|2018.0.0*

This is solved by adding “anaconda” as a channel.

Second we have:

Error: Could not find some dependencies for q2-diversity 2017.12|2017.12.0*: emperor 1.0.0beta13.*

If I try and install q2-diversity alone, I get:

%> conda install q2-diversity
Fetching package metadata: …
Solving package specifications:
Error: Could not find some dependencies for q2-diversity: emperor 1.0.0beta13.*

You can search for this package on Binstar with

binstar search -t conda emperor 1.0.0beta13.*

Hmmm. I see package emperor should be part of biocore.

I see from other posts that you only support “the latest” conda - can you tell me which version we need to be able to install qiime2?

Thanks
Mick

Hi @BioMickWatson!

Thanks for posting the workaround! Looks like another user had success with adding anaconda as a channel.

I think this either has something to do with the version of conda you have installed, conda’s cached packages, or the default channels you have in your conda config. See below for some debugging ideas.

conda or upstream package channels breaks things quite often (e.g. the jump from conda 4.3 to 4.4 opened up a whole slew of issues that we’re still trying to work through). Thus, there isn’t a recommended or required version of conda – upgrading to whatever the latest version is will often solve install problems. Currently, we are using conda 4.4, but will still recommend that users upgrade to the latest conda (whatever version that might be) if there are install-related issues.

Let’s try to get your QIIME 2 environment set up. Please try out these steps:

  1. Delete your existing QIIME 2 environment, in case there’s a partial environment that was created:

    conda env remove -n qiime2-2017.12
    
  2. Clear conda’s cached packages:

    conda clean --all -y
    
  3. Update conda to the latest version (currently conda 4.4):

    conda update conda
    
  4. Follow the native install guide to create a new qiime2-2017.12 environment.

If these steps don’t work, can you please provide the output from running conda info --all so that we can continue debugging? Thanks!

Hi

So I was using our cluster-wide installation of conda, which of course I cannot update.

So I downloaded and installed Miniconda locally, and followed the installation instructions.

This appeared to work, and I got the final message:

Executing transaction: done

To activate this environment, use:

> source activate qiime2-2017.12

To deactivate an active environment, use:

> source deactivate

So I activated the environment, then tried:

%> qimme

What I got was

QIIME is caching your current deployment for improved performance. This may take a few moments and should only happen once per deployment.
/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/importlib/_bootstrap.py:222: RuntimeWarning: compiletime version 3.4 of module ‘pandas._libs.tslib’ does not match runtime version 3.5
return f(*args, **kwds)
/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/importlib/_bootstrap.py:222: RuntimeWarning: builtins.type size changed, may indicate binary incompatibility. Expected 864, got 824
return f(*args, **kwds)
/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/importlib/_bootstrap.py:222: RuntimeWarning: compiletime version 3.4 of module ‘pandas._libs.tslibs.timezones’ does not match runtime version 3.5
return f(*args, **kwds)
/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/importlib/_bootstrap.py:222: RuntimeWarning: compiletime version 3.4 of module ‘pandas._libs.tslibs.parsing’ does not match runtime version 3.5
return f(*args, **kwds)
/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/importlib/_bootstrap.py:222: RuntimeWarning: compiletime version 3.4 of module ‘pandas._libs.tslibs.fields’ does not match runtime version 3.5
return f(*args, **kwds)
/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/importlib/_bootstrap.py:222: RuntimeWarning: compiletime version 3.4 of module ‘pandas._libs.hashtable’ does not match runtime version 3.5
return f(*args, **kwds)
/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/importlib/_bootstrap.py:222: RuntimeWarning: compiletime version 3.4 of module ‘pandas._libs.lib’ does not match runtime version 3.5
return f(*args, **kwds)
/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/importlib/_bootstrap.py:222: RuntimeWarning: compiletime version 3.4 of module ‘pandas._libs.interval’ does not match runtime version 3.5
return f(*args, **kwds)
Traceback (most recent call last):
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/bin/qiime”, line 11, in
sys.exit(qiime())
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 696, in main
with self.make_context(prog_name, args, **extra) as ctx:
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 621, in make_context
self.parse_args(ctx, args)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 1015, in parse_args
echo(ctx.get_help(), color=ctx.color)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 496, in get_help
return self.command.get_help(self)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 830, in get_help
self.format_help(ctx, formatter)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 845, in format_help
self.format_options(ctx, formatter)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 956, in format_options
self.format_commands(ctx, formatter)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 1000, in format_commands
for subcommand in self.list_commands(ctx):
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/q2cli/commands.py”, line 69, in list_commands
plugins = sorted(self._plugin_lookup)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/q2cli/commands.py”, line 53, in _plugin_lookup
import q2cli.cache
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/q2cli/cache.py”, line 302, in
CACHE = DeploymentCache()
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/q2cli/cache.py”, line 61, in init
self._state = self._get_cached_state(refresh=refresh)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/q2cli/cache.py”, line 107, in _get_cached_state
self._cache_current_state(current_requirements)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/q2cli/cache.py”, line 200, in _cache_current_state
state = self._get_current_state()
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/q2cli/cache.py”, line 232, in _get_current_state
import qiime2.sdk
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/qiime2/init.py”, line 10, in
from qiime2.metadata import Metadata, MetadataCategory
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/site-packages/qiime2/metadata.py”, line 15, in
import pandas as pd
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/mypython3.4/lib/python3.4/site-packages/pandas-0.21.0rc1-py3.4-linux-x86_64.egg/pandas/init.py”, line 26, in
from pandas._libs import (hashtable as _hashtable,
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/mypython3.4/lib/python3.4/site-packages/pandas-0.21.0rc1-py3.4-linux-x86_64.egg/pandas/_libs/hashtable.py”, line 7, in
bootstrap()
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/mypython3.4/lib/python3.4/site-packages/pandas-0.21.0rc1-py3.4-linux-x86_64.egg/pandas/_libs/hashtable.py”, line 6, in bootstrap
imp.load_dynamic(name,file)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/imp.py”, line 343, in load_dynamic
return _load(spec)
File “pandas/_libs/hashtable.pyx”, line 1, in init pandas._libs.hashtable
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/mypython3.4/lib/python3.4/site-packages/pandas-0.21.0rc1-py3.4-linux-x86_64.egg/pandas/_libs/lib.py”, line 7, in
bootstrap()
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/mypython3.4/lib/python3.4/site-packages/pandas-0.21.0rc1-py3.4-linux-x86_64.egg/pandas/_libs/lib.py”, line 6, in bootstrap
imp.load_dynamic(name,file)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/imp.py”, line 343, in load_dynamic
return _load(spec)
File “pandas/_libs/lib.pyx”, line 59, in init pandas._libs.lib
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/mypython3.4/lib/python3.4/site-packages/pandas-0.21.0rc1-py3.4-linux-x86_64.egg/pandas/_libs/interval.py”, line 7, in
bootstrap()
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/mypython3.4/lib/python3.4/site-packages/pandas-0.21.0rc1-py3.4-linux-x86_64.egg/pandas/_libs/interval.py”, line 6, in bootstrap
imp.load_dynamic(name,file)
File “/exports/cmvm/eddie/eb/groups/watson_grp/software/mickpython/qiime2-2017.12/lib/python3.5/imp.py”, line 343, in load_dynamic
return _load(spec)
File “pandas/_libs/hashtable.pxd”, line 7, in init pandas._libs.interval
AttributeError: module ‘pandas._libs.hashtable’ has no attribute ‘HashTable’

Any clues?

Thanks for the details @BioMickWatson! It looks like you have Python 3.4 and Python 3.5 conflicting with each other (specifically with the pandas package, which is a QIIME 2 dependency).

Can you please provide the output from running the commands below? First run all of the commands with the qiime2-2017.12 environment deactivated, then run the commands again with the qiime2-2017.12 environment activated. Some of the commands are expected to fail; please run them anyways and provide the output. Hopefully this will give me enough info to figure out what’s going on!

Debug commands:

uname -a
echo $PATH
echo $PYTHONPATH
echo $PYTHONHOME
ls -la $HOME/.local/lib
which python
python --version
alias python
which qiime
which conda
conda info -a
conda list
python -c "import pandas"

Thanks!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.