'mission option' error when trying to collapse table based on taxonomy

Hello,

Ive been using what you suggested to use for creating OTU table in Qiime2 and yesterday I had an error msg that says:

(1/2) Missing option ‘–o-collapsed-table’. ("–output-dir" may also be
used)
(2/2) Got unexpected extra argument ( )
/var/lib/slurmd/job2227746/slurm_script: line 22: --output-dir: command not found

my script was:
qiime taxa collapse
–i-table dada2_trial/table.qza
–i-taxonomy 99_otu_classifier_trial.qza
–p-level 7
–output-dir dada2_trial/

I also switched --output-dir dada2_trial/ to --o-collapsed-table dada2_trial.qza
it gave me similar results as missing options… so I really don’t know what is wrong??

Hi @Sammi ,
I made this post public as we try and avoid answering general questions via DMs. That way more people can benefit from both the question as well as the answer. Plus, it’s a faster way of getting help as more people will view it.

I think this may just be a simple error in syntax, can you try the below code exactly and let us know if it works? Also, copy & pasting from something like a word document is not recommended when it comes to coding as that can introduce special formatting that can cause other similar issues. Try:

qiime taxa collapse \
  --i-table dada2_trial/table.qza \
  --i-taxonomy 99_otu_classifier_trial.qza \
  --p-level 7 \
  --o-collapsed-table collapsed_table.qza #or whatever name you prefer here.

And let us know if that works.

2 Likes

Thank you!

Indeed, it was a simple syntax issue that I didn’t spot the “space”…I felt so bad… thank you again!!!

1 Like