missing file when converting from qza to qzv

I have been working with some sequencing data and have been having issues with the output visualization steps below:

qiime demux summarize --i-data demux.qza --o-visualization demux.qzv

qiime feature-table summarize --i-table table.qza --o-visualization table.qzv --m-sample-metadata-file sample-metadata.tsv

When these commands run, there is no error, however, the qzv file does not appear in my directory. I am able to generate taxonomy.qzv files but can’t generate other qzv files to visualize my data.

Is this a common occurrence? And is there a way around this?

Hello Bailey,

Welcome to the forums! :qiime2:


No, this is very spooky. :ghost:

Uh, how are you running these commands? Like, on a mac laptop, or a remote server by submitting jobs to a SLURM queue, or something else?

I ask because after running these commands, we should be able to see the output file by running ls and confirm the file location by running pwd. If this is remote server, sometimes files can be hard to track down... which would be a solvable and non-spooky explanation.

I'm running them via a terminal - Putty on my PC. It's strange because I can create and view taxonomy.qzv files from qza files but can't create the qzv files needed in the beginning to visualize my data. So I suppose it is a remote server! Any ideas where the file would be saved? Would it be on my local drive or within the server I am using?

If you are using putty, you are almost certainly connecting to a remote server.

ssh [email protected]
                 ^^^ this is the IP address of the remote server

Do you also make these files using the putty terminal, or do you make them another way?

How do you view the taxonomy.qzv files? Do you download them from the remote server, or from the internet somewhere?

Yes I make all files using the putty terminal. After the qzv files are created, I move them using WinSCP to my local drive and view them via QIIMEview. However, the file demux.qzv does not show up anywhere.

Got it!

OK, before or after running a qiime script, you can ls in the terminal to list the files in the current directory. WinSCP should show you which files are your current working directory, so you can download them like you have been doing.

So, it sounds like after running some commands, you don't see any new files using ls or WinSCP? What do you see after running that qiime command?

I'm looking for all the clues we can find! :female_detective:

here is what I see after I run the command.

here are my files after listing them all using ls

Wow, yeah that command looks fine to me, but I also can't see the output file listed in the current working directory.

What version of Qiime are you using? You can run qiime --version or qiime info to find out, and post the result here.

Could you also try running this command using a new working directory? I notice a lot of files in there, and I wonder if there's some sort of permission error that could be solve by making a new directory with mkdir, copying your input file there, then rerunning the demux summarize command from within the new folder.

I'm using Qiime 2019.10.0. Is there a way to upgrade my version of Qiime within Putty?

Here is my new working folder with only the qza file in it. I used this command to create the qza file.

qiime tools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-path /panfs/roc/groups/11/novakp/hadno004/working-folder --input-format CasavaOneEightSingleLanePerSampleDirFmt --output-path demux-paired-end.qza

Hello Bailey,

Yes, you could install a new version of Qiime2. However, it looks like you are using the qiime 2 module set up by a system administrator, so it might make sense to have a system admin install the new version of Qiime2 for you, then load it from the new module they provide.

I notice that your new folder has a file for errors .err and a file for standard out .out. Did you make those on purpose? Can you show me what's inside of them?

yes those were just from a job I submitted via SLURM. I actually figured it out! I switched from Mangi to Mesabi and that solved my problem. thanks for all your help!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.