Miniconda is installed but getting this error "zsh: command not found: conda"

Hi all,
I am a new user, trying to install miniconda3 in macbook M1. I believe I have successully installed it but I am still getting this error on any conda command:

zsh: command not found: conda

I have tried everything I could find online but its not working. Help is very much appreciated.
Thanks

Hello @Muhammad_Arslan1,

Welcome to the forums! :qiime2:

I'm also using an M1 mac, so let's see if we can get this working.

After installing conda, did you close that terminal window and open a new one? (The new window should recognize your new conda install, while the old window might not.)

If that new window does not work, try running conda init to initialize the conda command inside your terminal. Then try opening a new terminal windows and see if you can use conda commands.

It worked after reinstalling and restarting. However, another problem I am facing now. I am trying to install QIIME environment but getting this error.

(base) [email protected] ~ % conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-osx-conda.yml

Collecting package metadata (repodata.json): done
Solving environment: failed

ResolvePackageNotFound: 
  - bioconductor-iranges=2.28.0
  - hmmer=3.1b2
  - q2-dada2=2022.2.0
  - q2-types=2022.2.0
  - gfortran_impl_osx-64=9.3.0
  - bioconductor-dada2=1.22.0
  - q2-vsearch=2022.2.0
  - qiime2=2022.2.0
  - xopen=1.5.0
  - q2galaxy=2022.2.0
  - perl-compress-raw-bzip2=2.103
  - q2-quality-filter=2022.2.0
  - bioconductor-rhtslib=1.26.0
  - q2cli=2022.2.0
  - unifrac=0.20.3
  - bioconductor-shortread=1.52.0
  - bioconductor-xvector=0.34.0
  - q2-diversity-lib=2022.2.0
  - perl-io-compress=2.102
  - entrez-direct=16.2
  - blast=2.12.0
  - r-jpeg=0.1_9
  - q2-mystery-stew=2022.2.0
  - bioconductor-s4vectors=0.32.3
  - bioconductor-genomicalignments=1.30.0
  - scikit-bio=0.5.6
  - q2-feature-classifier=2022.2.0
  - python-isal=0.11.1
  - biom-format=2.1.10
  - bioconductor-zlibbioc=1.40.0
  - sepp=4.3.10
  - q2-cutadapt=2022.2.0
  - bowtie2=2.4.5
  - bioconductor-biobase=2.54.0
  - q2-alignment=2022.2.0
  - pbzip2=1.1.13
  - emperor=1.0.3
  - q2-metadata=2022.2.0
  - q2-longitudinal=2022.2.0
  - mafft=7.490
  - r-bitops=1.0_7
  - bioconductor-delayedarray=0.20.0
  - q2-emperor=2022.2.0
  - q2-diversity=2022.2.0
  - libgcc=4.8.5
  - raxml=8.2.12
  - q2-fragment-insertion=2022.2.0
  - bioconductor-rsamtools=2.10.0
  - q2-taxa=2022.2.0
  - htslib=1.15.1
  - q2-deblur=2022.2.0
  - dnaio=0.8.1
  - perl-list-moreutils-xs=0.430
  - perl-pathtools=3.75
  - q2-quality-control=2022.2.0
  - bioconductor-biocparallel=1.28.3
  - perl-encode=3.17
  - fasttree=2.1.10
  - q2-sample-classifier=2022.2.0
  - perl-scalar-list-utils=1.62
  - vsearch=2.7.0
  - perl-json-xs=2.34
  - q2templates=2022.2.0
  - libgfortran5=9.3.0
  - r-rcppparallel=5.1.5
  - samtools=1.15.1
  - cutadapt=3.7
  - isa-l=2.30.0
  - iqtree=2.2.0_beta
  - q2-phylogeny=2022.2.0
  - q2-gneiss=2022.2.0
  - perl-compress-raw-zlib=2.103
  - sortmerna=2.0
  - pandoc=2.17.1.1
  - r-vegan=2.5_7
  - bioconductor-genomicranges=1.46.1
  - gfortran_osx-64=9.3.0
  - fastcluster=1.2.6
  - q2-feature-table=2022.2.0
  - r-rcurl=1.98_1.6
  - q2-composition=2022.2.0
  - q2-demux=2022.2.0
  - bioconductor-biostrings=2.62.0


I am using this command

conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-osx-conda.yml

Any thoughts?

Wonderful, we got conda working!

For now, lots of software, including packages needed by qiime2, are not complied for the ARM architecture used by our M1 macs. Fortunately, Apple provided Rosetta 2 to run this software and this lets us run conda and Qiime2 on the M1 chip.

Even better, a member of the forums contributed a tutorial on how to install and run Qiime2 using Rosetta 2 .

Try that tutorial and let me know if you have any questions.

Colin

P.S. Lots conda packages run natively on the M1 mac, so you have made good progress!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.