metadata types specification raises error with cutadapt

Thanks for the tutorial!
I’ve been receiving exceptions when trying to use cutadapt commands with my metadata file. What fixed it is removing the “#q2:types” line (which I’ve been using in other projects where I did not use cutadapt for demultiplexing, as recommended here: https://docs.qiime2.org/2018.11/tutorials/metadata/).
Not sure whether this is a known issue or not, so FYI.

Thank you for reporting this @efratm!

For the sake of debugging on our end, could you please provide the full command you are running, and the exception that is raised?

Turns out the metadata file was indeed corrupted (it had a character value in a column defined as "numeric"). That's why removing the “#q2:types” line solved the issue.
Also, after the exception prints, there were details indicating exactly where the metadata parsing failed (I missed them).
I apologize for the misleading bug report!

I'm pasting the command + exception details below, just in case you're still interested:

Command:
qiime cutadapt demux-single --i-seqs mux_data.qza --m-barcodes-file metadata_with_types_corrupted.tsv --m-barcodes-column BarcodeSequence --p-error-rate 0 --o-per-sample-sequences demux_test.qza --o-untrimmed-sequences seqs_unmatched_to_barcodes_test.qza --verbose

Stderr:
Attached.stderr_METADATA_ERROR.txt (4.5 KB)

1 Like

Thank you for the clarification, @efratm!

No need to apologize! Thanks for sharing all of these details — this is a big part of what keeps open source afloat!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.