Metadata file error

Hi,

I am working on a meta-analysis in which I have created separate metadata files and combined into a large spreadsheet. I have run each studies data separately through DaDa2 and merged. I am attempting to perform taxonomy classification and core-metrics but qiime2 keeps kicking my metadata file back with numerous errors. I validated the metadata sheet with Keemei. I think the problem resides in the conversion of the .csv to .tsv or .txt. FYSA, I started with a google sheet and tried to save the different formats from this. Please find both formats attached. This is the last error I received:

image

Any assistance would be great!

updatedburnmetadata.csv (83.9 KB) updatedburnmetadata.tsv (83.9 KB)

Hi @horsemant!

We are missing some critical information here in order to effectively help you. Please provide the following:

  • The version of QIIME 2 used
  • The exact command or commands run (copy-and-paste, please)
  • The complete error log (either attach the log file referenced at the end of the error, or run with the --verbose flag.

Thanks! :qiime2:

Hi @thermokarst,

I am running qiime2 2021.4 in a Virtual Machine. The command is pasted below:

qiime taxa barplot
--i-table burndada2-merged.qza
--i-taxonomy ref-taxonomy-97.qza
--m-metadata-file updatedburnmetadata.txt
--o-visualization taxabarplotdada.qzv
--verbose

I apologize but how can I locate the log file. The --verbose command just said the debug information can be found above which is essentially what I took a snapshot of.....

You have two options:

  1. Run the command without the --verbose flag. At the end of the error will be a message that says "Debug info has been saved to /tmp/SOMETHING.log" - copy that "SOMETHING.log" file up here.
  2. Run the command with the verbose flag, and copy-and-paste the entire content here.

Your screenshot is missing the actual main part of the error message, its kind of like taking a screenshot of your message above that looks like this:

Screen Shot 2021-09-24 at 7.25.35 PM

Thanks!

1 Like

/tmp/qiime2-q2cli-err-ejnwhpyv.log

@horsemant - we need the file in order to help, you can copy its contents here, or "upload" it. Thanks.

@thermokarst,

Again, sorry for my ineptitude. I ran the --verbose command and have copied all the contents into the attached document. verbose error log.txt (771.2 KB)

Hi @horsemant - I don't think you've done anything wrong here! I'm sorry that my above messages implied otherwise, that certainly wasn't my goal.

Unfortunately the file you uploaded isn't the complete error message - its still missing the first part of it.

I can't say for sure what the issue is that you're observing, but my best guess is that you have a mismatch between the feature IDs in your FeatureData[Taxonomy] result (you named it ref-taxonomy-97.qza above) and your FeatureTable[Frequency] result (you named it burndada2-merged.qza). Every feature ID in the table must have a corresponding entry in the taxonomy file.

One hypothesis as to why this has happened is that you have provided the wrong taxonomy input here. Recognizing that filenames don't carry any particular meaning to QIIME 2, I do notice that you've used the word "ref" in the filename, which is usually short for "reference." If this is the same convention you have adopted here, then perhaps that's the issue? Usually people use their actual data in these visualizations, rather than a reference database. See this section of the Moving Pictures tutorial for an example.

Let us know if you have any questions. And if you're still running into issue, please make sure to copy-and-paste the entire error message - this takes a lot of the guesswork out of the process.

:qiime2:

Hi @thermokarst, you were correct. My metadata file was not the issue. It was based on my command insertion of --i-taxonomy ref line which I definitely did not need. I appreciate the assistance.

1 Like