Metadata column error

I have problems with this error running diversity analyses while choosing columns for the command. I have checked that I write the same name of the column as in the command, and it is correct, but still does not work... Do you have any suggestions to solve my problem?

Best regards
Jasmine

Hi @Jasmine84!

The error isn’t about your metadata - it is about the command itself:

no such option: --m-metadata-column

It looks like you are running QIIME 2 2017.12, but you are running commands based on the 2018.2 docs. There was a major overhaul to metadata in that release, and many arguments were renamed.

I would recommend you upgrade to the latest and greatest release of QIIME 2 (2018.2), but if you can’t, please change the selected version of the docs when viewing the docs at docs.qiime2.org, there is a little dropdown in the upper left corner, you can set this to 2017.12 to see that version of the docs. As well, on the CLI you can add --help to any command for the full list of options for each command.

Hope that helps! :t_rex:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.