Manifest is not a(n) PairedEndFastqManifestPhred64 file

import

(farhad) #1

Can someone please help me knowing what is the problem with my manifest file?
I have installed qiime2-2018.8, on ubuntu. my reads are paired-end fastq.gz
I run this command; “qiime tools import --type ‘SampleData[PairedEndSequencesWithQuality]’ --input-path manifest --output-path paired-end-demux.qza --input-format PairedEndFastqManifestPhred64”
I got this error: “There was a problem importing manifest:
manifest is not a(n) PairedEndFastqManifestPhred64 file”
my manifest file is as below;
"Sample-id,absolute-filepath,direction
P17-075-1,/home/farhad/gut/P17-075_S1_L001_R1_001.fastq.gz,forward
P17-075-2,/home/farhad/gut/P17-075_S1_L001_R2_001.fastq.gz,reverse
P17-083-1,/home/farhad/gut/P17-083_S2_L001_R1_001.fastq.gz,forward
P17-083-2,/home/farhad/gut/P17-083_S2_L001_R2_001.fastq.gz,reverse
"
I have put manifest and reads in same directory.
I appreciate any help


(Devon O'rourke) #2

Hi @farhad63,
Are you positive it’s encoded with Phred64 and not Phred33? Here’s one post that helps figuring that out. My guess is you might just have an input format that is PairedEndFastqManifestPhred33.
Couldn’t hurt to try and see if the error goes away…


(farhad) #3

Hi Devon
Thanks for the reply. I think I should not use manifest to import my data (I should use casava related command) as it it is fastq.gz and not fast q?


(Devon O'rourke) #4

Hi @farhad63,
I think you’re combining two separate ideas here:

  1. The file may be compressed (.fastq.gz) or uncompressed file (.fastq).
  2. The file may be imported with one of several import types, including either the Casava flavor or via the Manifest file method. There are many ways to get data into QIIME as outlined in this document.

As I understand it, compression has nothing to do with whether you import the format with the Manifest option or the Casava style. What does matter is the nature of the organization of your data. If you don’t find that your format fits with anything that is described in that document there are other ways to get your data into QIIME; I’d suggest describing a bit more about how you generated these sequences so the pros who monitor these sites can help point you in the right direction. Think about whether your data is demultiplexed or not, whether you have single or paired end data, whether or not you have trimmed the barcodes from your data already, etc.

Cheers,
Devon


(farhad) #5

Hi Devon Thanks for the help
I have paired-end read of 18S got demultiplexed by sequencing company as fastq.gz file (one forward & one reverse file for each sample)


(Matthew Ryan Dillon) #6

Thanks for the tips, @devonorourke!

@farhad63, first off, if you update to the latest release of QIIME 2 you will receive a much more detailed error message telling you exactly what is wrong with your manifest file. I just took a quick glance and noticed a typo in the first line:

You have a capital s here (S), but it should be lower-case (s). Make those changes and give it a shot! :qiime2:


(farhad) #7

thanks it worked, appreciate


(Nicholas Bokulich) #8

An off-topic reply has been split into a new topic: –o-denoising stats: command not found

Please keep replies on-topic in the future.