Manifest file not a directory

Dear Qiimers,

After using Qiime for some time, I feel ready to take the big stepa nd move to Qiime2 :slight_smile:

As I normally start my pipeline with demultiplexed paired-end files, I am tryng to import such files into Qiime2. here's my command line:

qiime tools import \
    --type 'SampleData[PairedEndSequencesWithQuality]' \
    --input-format CasavaOneEightSingleLanePerSampleDirFmt \
    --input-path manifest.2.txt \
    --output-path ./

Unfortunately I receive the following error message:

There was a problem importing manifest.2.txt:

manifest.2.txt is not a directory.

Can you please advice?

Thank you, and wish you Happy Holidays

Hello Max,

According to this tutorial, the --input-path should be the folder holding your fastq files. Other --input-formats will use a manifest file, but not --input-format CasavaOneEightSingleLanePerSampleDirFmt.

Let me know if that works for you and keep on following those tutorials!



Hi, Colin,

Thank you for your kind answer. I replaced the manifest file with the folder holding my fastq, and the program run successfully.
I am a bit confused at this point; how does Qiime2 know which file to use as manifest? Does it check all the text files in the working directory?

Thanks again for your help,

Hi Max,

Ok great! I’m glad that ran.

Nope. Qiime 2 only cares about the files you pass as input, and the location of the output.

I think the confusion is coming from all the different --input-formats that Qiime supports, and how it handles them differently. Take these two formats as examples:

  1. --input-format CasavaOneEightSingleLanePerSampleDirFmt
    This format opens up the --input-path folder, then it looks for fastq files inside that folder and makes one sample for each fastq file.
  2. --input-format SingleEndFastqManifestPhred33
    This format opens up the --input-path file, then it looks for fastq files listed in that file and makes one sample for each fastq file.

Does that make sense?


According to the documentation:

The manifest file is a comma-separated (i.e., .csv ) text file.

…So why don’t the examples on the website end with .csv? Looks like I missed that discussion. @thermokarst @mortonjt


Oh, I see, I understand now.

I have just tried to run the command from a different folder, without the manifest file, and it worked as well.

So, no need for manifest file when using

--input-format CasavaOneEightSingleLanePerSampleDirFmt

I had missed that. Thank you for your explanation, I appreciate it.



Thanks @colinbrislawn!

Extensions are just a convention, you could have a comma-separated-values file that was called my-data.colinbrislawn and it would still technically be a CSV!

1 Like

hello mr colinbrinslawn and mstaglimonte, pls i have the same issue i dont get what do you mean by the manifest file. i gather all the fastq gz file in one folder but i cant find it when i run "ls" to put it as input path

Hi, @Amine_taouil ,

If you cannot find the files with ls, you are either in the wrong directory or you copied the files to a different directory than you intended.

Good luck with the long journey of learning command line and bioinformatics :slightly_smiling_face: :+1:

1 Like