Manifest file import failed

Hello I am using qiime2-2020.11 and have a problem importing manifest file (demultipled data). Any help is much appreciated.

the error return is bellow.

zsh: no matches found: ‘SampleData[PairedEndSequencesWithQuality]’ --input-path

Here is the script I used:

qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path ManifesFile.tsv
–output-path demux.qza
–source-format PairedEndFastqManifestPhred33

Hi @baronhabtom,

Welcome to the :qiime2: forum!

I think the issue, based on what you’re showing here, is possibly that you didn’t wrap your text correctly. You need to use the \ character between lines, so your re-formatted command would look like this:

qiime tools import \
 --type 'SampleData[PairedEndSequencesWithQuality]' \
 --input-path ManifesFile.tsv \
 --output-path demux.qza \
 --source-format PairedEndFastqManifestPhred33

if this isn’t correct, could you please copy and paste the command from the terminal? You can format it like text using the (`) symbol.

Best,
Justine

1 Like

Hi Justine, thank you for your kind support. I get two different errors: one is when the code is in one line and there is when the code is wrapped.

Error1:
(qiime2-2020.11) [email protected] bioner % qiime tools import --type ‘SampleData[PairedEndSequencesWithQuality]’ --input-path ManifestFile.tsv --output-path demux.qza --source-format PairedEndFastqManifestPhred33
Usage: qiime tools import [OPTIONS]

Import data to create a new QIIME 2 Artifact. See https://docs.qiime2.org/
for usage examples and details on the file types and associated semantic
types that can be imported.

Options:
–type TEXT The semantic type of the artifact that will be
created upon importing. Use --show-importable-types
to see what importable semantic types are available
in the current deployment. [required]
–input-path PATH Path to file or directory that should be imported.
[required]
–output-path ARTIFACT Path where output artifact should be written.
[required]
–input-format TEXT The format of the data to be imported. If not
provided, data must be in the format expected by the
semantic type provided via --type.
–show-importable-types Show the semantic types that can be supplied to
–type to import data into an artifact.
–show-importable-formats
Show formats that can be supplied to --input-format
to import data into an artifact.
–help Show this message and exit.

                There was a problem with the command:                     

(1/1?) no such option: --source-format
(qiime2-2020.11) [email protected] bioner %

Error2:
(qiime2-2020.11) [email protected] bioner % qiime tools import\

–type ‘SampleData[PairedEndSequencesWithQuality]’\

–input-path ManifestFile.tsv\

–output-path demux.qza\

–source-format PairedEndFastqManifestPhred33

Usage: qiime tools [OPTIONS] COMMAND [ARGS]…

Try ‘qiime tools --help’ for help.

Error: No such command ‘import–type’.

zsh: command not found: --input-path

zsh: command not found: --output-path

zsh: command not found: --source-format

(qiime2-2020.11) [email protected] bioner %

Hi @baronhabtom,

If you check the output error, you’ll find the problem with the first command in the docs:

Is there a --source-format flag in for this command? (Note that I reformmated above based on the command verses going in depth wtih the help docs. I recommend checking the docs for pretty much any command you run and (--help will print them for you.)

In your second error, it looks like you didn’t prefix the “” with a space. So, qiime tools import\ should be qiime tools import \, etc fo the rest of the commands.

Best,
Justine

Hi Justine,
Thank you for your quick and kind support. I found my mistake. It was the apostrophe mark around the command, –type ‘SampleData[PairedEndSequencesWithQuality]’
In my macbook I have three types of these and wasn’t aware that they are so different.

Thank you,
Howard

Hi @baronhabtom,

I’m glad you sorted it out! And yeah, depending on the keyboard and language it can be hard. I have a non-english keyboard, and there is a way to change the layout on a macbook (you can switch your preferred languages if you need to be multi-regional), which semi helps. You can also use double quotes (") in place of the single quote there.

Best,
Justine

The no-space between the command and backslash noticed in the second error was also another problem.
Thank you

1 Like