Manifest File for Importing Data

I am having an issue with importing my fastq data. I am using the 2017.7 form of QIIME 2.

I am using this as a practice run for when I have the full of my data. My files are under a directory still in their .gz format. The command I have been using to import them is

qiime tools import \
  --type SampleData[PairedEndSequencesWithQuality]' \
  --input-path import_file_fastq.txt \
  --output-path paired-end-demux.qza \
  --source-format PairedEndFastqManifestPhred33

However I am not sure if it is the correct one to use.

The error I have been receiving is:

    return cls._from_view(type_, view, view_type, provenance_capture)
  File "/mnt/lustre/software/anaconda/colsa/envs/qiime2-2017.7/lib/python3.5/site-packages/qiime2/sdk/$
    result = transformation(view)
  File "/mnt/lustre/software/anaconda/colsa/envs/qiime2-2017.7/lib/python3.5/site-packages/qiime2/core$
  File "/mnt/lustre/software/anaconda/colsa/envs/qiime2-2017.7/lib/python3.5/site-packages/qiime2/core$
  File "/mnt/lustre/software/anaconda/colsa/envs/qiime2-2017.7/lib/python3.5/site-packages/qiime2/plug$
    % (self.path, self.__class__.__name__))
ValueError: InPath('import_file_fastq.txt') is not formatted as a PairedEndFastqManifestPhred33 file.

I have followed how to do the manifest file form the importing tutorial, but I am unsure of what I am doing wrong. Attached is the file I am currently using. It's written through excel-->notepad. Import_file_fastq.txt (4.0 KB)
It's a .txt file and I don't know if that's the reason it's not being formatted correctly, but I have also tried a .csv file and it did not work either. Any help is appreciated.

Thanks for attaching your file! It looks to me like there are just a couple of broken newlines. If you open it in notepad again, you should see them. Each row is supposed to be a single line, but some of the rows span two lines. (I've attached the same file with the newlines fixed).

Import_file_fastq-fixed.txt (4.0 KB)

Let me know if that works better.

Unrelated, but would you happen to know why your reverse reads are labelled as _R3_? I've never seen that before.

1 Like

I had redone the file in excel and in notebook, found there were spaces after the sample absolute files, which caused the issue. Thank you for your help, it worked!

And I have no idea why R3 is the reverse, but R2 is definitely a much smaller file so I was assuming it was barcodes- as the entirety came out demultiplexed when given to me from the genome center.


Data can be pretty messy in this field. ¯\_(ツ)_/¯ If your reads fail to merge, maybe double check this assumption, but sounds like you are squared away!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.