Kernel panic on windows

Good Morning,
I’m trying to learn using qiime2 but when I start it, there’s kernel panic-not syncing:VFS: unable to mount root fs on unknown-block.
My laptop is windows 10.
How can I repair this error?
Thank you so much

Hello Paolo,

Thanks for trying out Qiime 2! :qiime2:

Are you running this using Windows Subsystem for Linux or using a VM?

Colin

I’m running this using a VM 6.0.14
What can I do?
Thak you for your replay
Paolo

Ah, OK!

If you are using a VM, you will need to make sure that Virtualization is enabled on your host computer. You can make sure it’s enabled by checking your BIOS or UEFI settings.

Here’s one guide about how to do this:

I suspected that you are getting this error because virtualization is turned off, and once you turn it on your VM will work great!

Colin

My virtualization is enabled. I’ve been on BIOS to modify it and is enabled.
Do you advise me to change computer? and which computer should I take?
Because I don’t know how to do.
Thanks
Paolo

OK great!

Nope. Now that you have enabled virtualization, try running this again and see if you have any issues or errors.

Thank you Paolo,
Colin

Thank you Colin for your kindness.
But I’ve already done it but it doesn’t work :smile: :disappointed_relieved:
I don’t know how to do it.
Paolo

Oh OK.

Any modern Intel of AMD x86 processor should have virtualization as a built-in option, and they are called Intel VT-x and AMD-V respectively. If you see those terms on processor specification, you will be good to go!

Colin

P.S. (I edited your post so your emoji work:scream_cat:-> :scream_cat: )

I have a Intel (R ) Core (TM )i7-4510U CPU @2.00 GHz 2.60 GHz.
Is not good? :thinking:
Paolo

Hi @Paolo_D_Avino - this sounds fine. The kernel panic you provided above sounds like for some reason virtualbox can’t read the hard disk image - any chance you deleted the file on accident? Or perhaps your user account doesn’t have permission to read these files?

No, because the day before it worked. The day after no. Maybe some update of the computer?
I don’t know what is the origin.
Does not exist a solution to kernel panic? :slight_smile:
Thank you
Paolo

This is an important clue! If virtualization was working then, it should continue to work now…

I second Matt’s suggestion about checking in on the VM files. You could also try downloading a new copy of the Qiime VM.
https://docs.qiime2.org/2019.10/install/virtual/virtualbox/

Colin

I’ve already downloaded it more times. But there’s always kernel panic:disappointed_relieved:
Paolo

Ah, OK. Maybe it’s an issue with the VM. Have you tried reinstalling VirtualBox?

Yes, I’ve done it also.
I don’t know if there’s a problem of my laptop or not.
In my brother’s laptop it works without problems.

Great!

because the day before it worked.

… On your brothers laptop or yours? Has it ever worked on your laptop?

Your brother’s laptop could have virtualization and yours might not… so even if the file is fine, it will never run a laptop that is missing virtualization. :computer: :computer:

On my laptop it worked the day before. I asked to my brother to verify if it’s in your computer works to see if there’s a problem on mine.
Because the virtualization is enabled on my pc.
I’ll figure it out

1 Like