Issues with q2-ghost-tree .nwk file


#1

I am trying to import a pre-built ghost-tree following the guidelines in this tutorial, but I get the error:

There was a problem importing ghost_tree.nwk:

ghost_tree.nwk is not a(n) NewickFormat file

I have selected this pre-built tree to try & get further in my analysis, but I cannot proceed. I feel like I’m missing something obvious, but I cannot figure out where I’m going wrong. I am having difficulty getting back in the groove of things after recovering from “the crud”, so I’m probably overlooking something simple.

Any help is much appreciated.


(Matthew Ryan Dillon) #2

Hey there @jhines1! Can you provide some more specifics, like, what version of QIIME 2 are you running, what is the exact command you ran, and what is the complete error message observed? Thanks!


(Jennifer Fouquier) #3

Hi @jhines1! :slight_smile:,

I just tried importing it and I get the green light from QIIME 2. I’m using QIIME 2019.1. I just wanted to make sure that file specifically works, but please follow up with Matt’s questions if it’s still not working for you. -Jennifer

wget https://raw.githubusercontent.com/JTFouquier/ghost-tree-trees/master/silva-132-foundation/01.12.2017/ghost_tree_80_qiime_ver7_99_01.12.2017/ghost_tree.nwk
--2019-03-04 14:50:00--  https://raw.githubusercontent.com/JTFouquier/ghost-tree-trees/master/silva-132-foundation/01.12.2017/ghost_tree_80_qiime_ver7_99_01.12.2017/ghost_tree.nwk
Resolving raw.githubusercontent.com... 151.101.68.133
Connecting to raw.githubusercontent.com|151.101.68.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1347120 (1.3M) [text/plain]
Saving to: 'ghost_tree.nwk'

ghost_tree.nwk                    100%[==========================================================>]   1.28M  4.61MB/s    in 0.3s

2019-03-04 14:50:01 (4.61 MB/s) - 'ghost_tree.nwk' saved [1347120/1347120]

(qiime2-2019.1) [email protected] Pro:~/Desktop$ qiime tools import --input-path ghost
ghost-tree-collapse/ ghost_tree.nwk
(qiime2-2019.1) [email protected] Pro:~/Desktop$ qiime tools import --input-path ghost
ghost-tree-collapse/ ghost_tree.nwk
(qiime2-2019.1) [email protected] Pro:~/Desktop$ qiime tools import --input-path ghost_tree.nwk --type Phylogeny[Unrooted] --output-path ghost-tree-unrooted.qza
Imported ghost_tree.nwk as NewickDirectoryFormat to ghost-tree-unrooted.qza 


#4

I am using qiime2-2019.1. The error message I received was in my OP. That was all it said. I am about to head to a meeting, then home, but I will respond with the exact code first thing tomorrow morning.

I’m sure I just overlooked something. It’s good to know @Jennifer_Fouquier got it to go through. It’s most likely something silly on my end.

Thanks & I’ll be in touch.


(Matthew Ryan Dillon) #5

How about the full command you ran?


#6

Unfortunately, I don’t have access to that at the moment. I am using the Mac in the lab & I didn’t have time to save my editor to Google Drive before I had to leave. I’ll look it over tomorrow & post the full command in the morning when I get back to the lab.

Thanks/sorry!


#7

Sorry for the delayed response, but I got it to work. I’m not sure what I did any different from yesterday, but it saved from .nwk to .qza today. Maybe the Mac was just having a case of the Monday’s or something.

Either way, thank you so much for the quick responses & the help!! Much appreciated!