Issues installing QIIME2 in Centos6.9

Hello Everyone!

When I installed qiime2-2021.2 in my school's server(Centon6.9), I ran 'qiime --help' and found no response;
How could this happend,please help me!

(qiime2-2021.2) [[email protected] qiime2-2021.2]$ qiime --help
-bash: qiime: command not found

Hey Rainjie,

Welcome to :qiime2: forum!

That's weird, I use qiime2 in Centos 6.6 pretty much everyday and so far the OS hasn't been an issue, how do you know the error comes from Centos? (I think the distribution you're using is Red hat, package rhel/6.8...), how did you install qiime2?

Cheers,
Luis Alfonso.

Thanks for your help. I install qiime2 used the command ‘conda env create -n qiime2-2021.4 --file qiime2-2021.4-py38-linux-conda.yml’,and when I install qiime2 ,I found lots of conflict. so what can i do?

Thanks for your help. Can i ask you one more question?
I have successfully installed QIIME2-2020.11 Version on the server(The latest version-2021.4 cannot be installed on the server, but the QIIME2-2020.11 Version can be installed. That is so strange and I don't know why.) .when I source qiime2-2020.11.env, it's OK,but when I command 'qiime', it goes wrong. I am using Windows Subsystem for Linux(64-bit) --Ubuntu.


But when I run the UBUNTU 18.04 operating system,everything is OK.
Can you help me with this problem?

Hi there @Rainjie!

Your server environment has some outdated software in it, namely glibc - your conda info output shows us that you have 2.12, however some of the dependencies in the QIIME 2 2021.4 environment require 2.17 (or greater). You'll need to consult with your sysadmin to see if there are any system updates that can be applied to the server.

Keep us posted!

:qiime2:

3 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.