Issue with loading the file sample-metadata.tsv as metadata

Hi,

I have prepared a metadata file (attached within post), saved it in the .tsv format and Keemei have approved it, but it was not recognised by the qiime2 when I tried to run the command below.

sample-metadata-Otago.tsv (9.2 KB)

Error code as below:

$ qiime metadata tabulate --m-input-file sample-metadata-Otago.tsv --o-visualization tabulated-metadata.qzv

"There was an issue with loading the file sample-metadata-Otago.tsv as metadata:

Found unrecognized ID column name 'ID97H1f,TAGGCATGAAGGAGTA,CCTACGGGNGGCWGCAG,B2_ST7H2_58,S1,1,Before_Surgery,Infection_Blasto,ST7H_infected,9,2,12,Fecal_defecate' while searching for header. The first column name in the header defines the ID column, and must be one of these values:

Case-insensitive: 'feature id', 'feature-id', 'featureid', 'id', 'sample id', 'sample-id', 'sampleid'

Case-sensitive: '#OTU ID', '#OTUID', '#Sample ID', '#SampleID', 'sample_name'

There may be more errors present in the metadata file. To get a full report, sample/feature metadata files can be validated with Keemei: https://keemei.qiime2.org

Find details on QIIME 2 metadata requirements here: Metadata in QIIME 2 — QIIME 2 2019.7.0 documentation "

I looked through other similar posts in the forum, tried the suggestions but they did not work for me.

I have prepared another metadata file for a different run and that file was working fine.

Hopefully someone could advise / point out any errors.

Thank you.

Hi @mickohy,

Welcome to the forum!

When I open the file you attached, it’s a comma separated file instead of a tab separated file. So, try using a tab delimiter instead, and I think it should otherwise work. (If you did it in excel, just double check that you picked tsv… it happens to everyone at least one).

Best,
Justine

2 Likes

Hi @jwdebelius,

Thanks for the prompt reply.

I tried to save the file as .tsv but somehow it got reverted back to .csv .

I have since save the metadata file as .txt (since Qiime2 accept this format) and it seemed to work.

Thank you.

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.