Issue using "qiime tools view" - Ubuntu 22.04 LTS

Hello all!

I've just begun using QIIME 2 with the goal of performing some taxonomic analyses for a research project I am assisting with over the summer. I have QIIME 2 2022.2 installed in an Ubuntu 22.04 LTS 64-bit virtual machine (VMware Workstation 16 Player) using the native conda installation for Linux and am having some trouble working through the "Moving Pictures" tutorial.

I run into my issue when running the qiime tools view demux.qzv command. Firefox opens, but it gives a file not found error. Looking back in my terminal I see the following error:

Gtk-Message: 15:10:03.158: Failed to load module "canberra-gtk-module"

I am assuming this module loading failure is related to Firefox not being able to load the requested view. To that end, I have tried a slew of commands to the tune of sudo apt install libcanberra-gtk-module to no avail.

Does anyone have any advice on how to remedy this issue? I should mention that I'm just going to use QIIME 2 View in the meantime, so this issue isn't preventing me from working, but it is still something I would like to solve.

Thank you!

Hi @tothco,

Welcome to the :qiime2: forum!

This is interesting - my first suggestion would have also been to try installing libcanberra-gtk-module. Can you try the following command (just to make sure we're covering all iterations for this module):

sudo apt-get install libcanberra-gtk*

Let me know if this doesn't solve the issue, and we can keep digging! :hammer_and_wrench: :hole:

1 Like

Hello @lizgehret!

I have actually tried that command already; apologies for not being more specific in my original post. The whole list of commands that I have tried so far is as follows:

sudo apt install libcanberra-gtk-module
sudo apt install libcanberra-gtk*
sudo apt install libcanberra-gtk-module:i386
sudo apt install libcanberra-gtk*:i386

None of these have resolved the problem.

1 Like

Hi @tothco,

Thanks for sharing that list of commands, that's helpful in narrowing down what hasn't worked thus far - here's a similar command that seemed to work for a large number of folks who had this same problem (from askubuntu.com):

sudo apt install libcanberra-gtk-module libcanberra-gtk3-module

Hope this helps! :lizard:

Unfortunately, that didn't work either. :confused:

Both of the packages in that command are reported as already installed and up-to-date. I believe libcanberra-gtk-module was already installed by the first command in my previously mentioned list and that libcanberra-gtk3-module was already installed by the second.

Hi @tothco,

Thanks for trying that! Could you provide a full page screenshot of your attempt to use qiime tools view along with the entire error message? This may help clue us in to see if there's anything we're missing with this error. Thanks! :lizard:

1 Like

Hi @lizgehret,

Apologies for the quite late response. I've attached two sets of screenshots, terminal_1.png/firefox_1.png and terminal_2.png/firefox_2.png. The first set shows my terminal and browser when running qiime tools view demux.qzv after a fresh boot of my VM, and the second set shows the same stuff being run one more time. I include the two sets of screenshots because I got more errors than I originally remembered getting when I first ran the command after booting the VM, but the second set of screenshots looks more as I remember when originally starting this thread.

Thank you for your help as always!




Hi @tothco,

Thanks for providing those screenshots!

It looks as though there may be some configuration issues on your machine - in your screenshots, part of the error is a permission denied message and there is something going on with LibreOffice. This is something I'd recommend reaching out to your sysadmin to help troubleshoot, as these configuration issues are outside the scope of QIIME 2. In the meantime, you can just continue using QIIME 2 View!

Cheers :lizard:

1 Like