issue installing qiime2 on wsl

I am currently trying to download qiime2 on the wsl,and have updated conda in both powershell and the anaconda prompt, and can successfully run wget https://data.qiime2.org/distro/core/qiime2-2022.8-py38-linux-conda.yml
when i try to load the second line conda env create -n qiime2-2022.8 --file qiime2-2022.8-py38-linux-conda.yml i get the error SpecNotFound: Invalid name 'qiime2-2022.8', try the format: user/package
I have tried to log in to anaconda, but think it may be an issue with the conda environment
When i go to see my conda environments this what i get

conda environments:

base * C:\Users\hallz\miniconda3

i read something about changing the yml but was unsure of how to do this. thanks for any help!

Hello Zoey,

Are you running this from the anaconda prompt and powershell, or inside of the WSL terminal?

I ask because while anaconda is cross platform, Qiime2 only works on Unix systems like WSL and will not work on Windows native terminals. So you will have to use WSL for all installation steps.

Gotcha! Worked perfectly, thank you!

1 Like