Is there any way to install qiime2 packages locally?

I had some troubles to install qiime2 packages or modules (starts with ‘q2-’) on Linux system (for some firewall issue), so I tried to downloaded them manually and installed them using 'conda install --offline '. It worked well when I typed ‘qiime --help’. However, when I ran some commands like ‘qiime demux’, it returned “Error: QIIME 2 has no plugin/command named ‘demux’.”, but I am pretty sure that I have already installed q2-demux package manually. Is there anyone who can help me out?

Hello Zhe,

Welcome to the Qiime 2 forums! :qiime2:

How are you installing the different Qiime 2 plugins? If you are following these instructions and adding the --offline flag to conda?
Natively installing QIIME 2 — QIIME 2 2019.7.0 documentation

There has got to be a good way to to an offline install, so once we know more about your setup we can help you find out how best to install Qiime.


You can check if it has been installed by running conda list q2-demux — if it shows up in the output, then it is installed. If it is installed, but isn’t showing up in q2cli, you might still need to run qiime dev refresh-cache in order to tell q2cli that there are new plugins installed for it to discover. Hope that helps!


Hi Colin,

Thanks for your reply. Yes, I followed the instructions ( But it got stuck while downloading and extracting all of the q2 plugins due to the internet issues in our Linux cluster. However, I managed to download these missing plugins using my laptop (mac os) :joy:

Then I installed these missing plugins manually using "conda install --offline " which worked smoothly. At last I removed lines with “q2” plugins in yml file and reran the command “conda env create -n qiime2-2019.7 --file qiime2-2019.7-py36-linux-conda.yml” which did not throw out any error message.

I suggested that the plugins I installed manually might not be integrated in qiime env well. Is there any suggestions?


1 Like

Thanks Matthew for your suggestions. It seems that q2-demux has shown up in the output of command conda list q2-demux. I have tried qiime dev refresh-cache, but it does not help me to integrate q2 plugins into qiime env.

1 Like

Please provide the following:

conda list


qiime info


OK. Below is the conda list information.

~$ conda list
# packages in environment at /public/software/miniconda3:
# Name Version Build Channel
_libgcc_mutex 0.1 main defaults
asn1crypto 0.24.0 py37_0 defaults
bibtexparser 1.1.0 pypi_0 pypi
bzip2 1.0.8 h7b6447c_0 defaults
ca-certificates 2019.5.15 1 defaults
certifi 2019.6.16 py37_1 defaults
cffi 1.12.3 py37h2e261b9_0 defaults
chardet 3.0.4 py37_1003 defaults
click 7.0 pypi_0 pypi
conda 4.7.12 py37_0 defaults
conda-package-handling 1.3.11 py37_0 defaults
cryptography 2.7 py37h1ba5d50_0 defaults
decorator 4.4.0 pypi_0 pypi
future 0.17.1 pypi_0 pypi
idna 2.8 py37_0 defaults
libarchive 3.3.3 h5d8350f_5 defaults
libedit 3.1.20181209 hc058e9b_0 defaults
libffi 3.2.1 hd88cf55_4 defaults
libgcc-ng 9.1.0 hdf63c60_0 defaults
libstdcxx-ng 9.1.0 hdf63c60_0 defaults
libxml2 2.9.9 hea5a465_1 defaults
lz4-c h14c3975_0 defaults
lzo 2.10 h49e0be7_2 defaults
ncurses 6.1 he6710b0_1 defaults
numpy 1.17.2 pypi_0 pypi
openssl 1.1.1d h7b6447c_1 defaults
pandas 0.25.1 pypi_0 pypi
pip 19.2.2 py37_0 defaults
pycosat 0.6.3 py37h14c3975_0 defaults
pycparser 2.19 py37_0 defaults
pyopenssl 19.0.0 py37_0 defaults
pyparsing 2.4.2 pypi_0 pypi
pysocks 1.7.0 py37_0 defaults
python 3.7.3 h0371630_0 defaults
python-dateutil 2.8.0 pypi_0 pypi
python-libarchive-c 2.8 py37_13 defaults
pytz 2019.2 pypi_0 pypi
pyyaml 5.1.2 pypi_0 pypi
q2-alignment 2019.7.0 py36_0
q2-composition 2019.7.0 py36_0
q2-cutadapt 2019.7.0 py36_0
q2-dada2 2019.7.0 py36_0
q2-deblur 2019.7.0 py36_0
q2-demux 2019.7.0 py36_0
q2-diversity 2019.7.0 py36_0
q2-emperor 2019.7.0 py36_0
q2-feature-classifier 2019.7.0 py36_0
q2-feature-table 2019.7.0 py36_0
q2-fragment-insertion 2019.7.0 py36_0 file:///home/zz/software/qiime2
q2-gneiss 2019.7.0 py36_0
q2-longitudinal 2019.7.0 py36_0
q2-metadata 2019.7.0 py36_0
q2-phylogeny 2019.7.0 py36_0
q2-quality-control 2019.7.0 py36_0
q2-quality-filter 2019.7.0 py36_0
q2-sample-classifier 2019.7.1 py36_0
q2-taxa 2019.7.0 py36_0
q2-types 2019.7.0 py36_0
q2-vsearch 2019.7.0 py36_0
q2cli 0+unknown pypi_0 pypi
q2templates 2019.7.0 py36_0
qiime2 0+unknown pypi_0 pypi
readline 7.0 h7b6447c_5 defaults
requests 2.22.0 py37_0 defaults
ruamel_yaml 0.15.46 py37h14c3975_0 defaults
setuptools 41.0.1 py37_0 defaults
six 1.12.0 py37_0 defaults
sqlite 3.29.0 h7b6447c_0 defaults
tk 8.6.8 hbc83047_0 defaults
tqdm 4.32.1 py_0 defaults
tzlocal 2.0.0 pypi_0 pypi
urllib3 1.24.2 py37_0 defaults
wget 1.20.1 h20c2e04_0 defaults
wheel 0.33.4 py37_0 defaults
xz 5.2.4 h14c3975_4 defaults
yaml 0.1.7 had09818_2 defaults
zlib 1.2.11 h7b6447c_3 defaults
zstd 1.3.7 h0b5b093_0 defaults

And then qiime inforation is

:~$ qiime info
System versions
Python version: 3.7.3
QIIME 2 release: 0+unknown
QIIME 2 version: 0+unknown
q2cli version: 0+unknown


1 Like

Perfect, thanks @Endlare!

Looks like all your plugins are installed fine, but, I see a problem here:

Looks like these are not the conda packages for qiime2 and q2cli. You will need to uninstall these and reinstall the conda packages, then you should be in good shape!