... is not a(n) TSVTaxonomyFormat file

I am trying to run

qiime2 tools import  --type FeatureData[Taxonomy]

on a custom built input file (based on NCBI Taxonomy), which gives me the the above-mentioned error.
I could not find the exact specification for the required input. The documentation says: “…there isn’t currently documentation detailing which data formats can be imported as which QIIME 2 data types”

The lines in my file have the format:


Does the taxonomystring have to be in a specific format? I tried many different ones!

Also, the –source-format HeaderlessTSVTaxonomyFormat option is not there again.
Do I need a header? If yes how does it have to look like?

I also tried to import taxonomy files from silva (SILVA_132_QIIME_release/taxonomy/16S_only/97/consensus_taxonomy_7_levels.txt) and greengenes (gg_13_8_otus/taxonomy/97_otu_taxonomy.txt) database to compare the results – with the same error.

I am using:
QIIME 2 release: 2018.11
QIIME 2 version: 2018.11.0
q2cli version: 2018.11.0

What am I doing wrong?

No, you are following the correct format. However, special characters (including invisible characters like abnormal line endings) might be causing this issue.

It is there. Try --input-format HeaderlessTSVTaxonomyFormat

This makes me think that you are just importing as the wrong input-format (see above), not the way that your file is formatted.

If you are still having issues, please share the exact commands that you are using. You can see here for an example of importing the greengenes reference files.

Good luck!

1 Like

–input-format HeaderlessTSVTaxonomyFormat fixed it!

I overlooked it several times when reading the docs :man_facepalming: – Thank you!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.