Ion Torrent Importing data

Hi to all,

I’m a very beginner in qiime2. I hope you could help me.
I have 4 fastaq files each one containig 48 samples, which have been sequentiated with Ion Torrent platform. I have gone through the forum and, as many people suggested, I would like to import my data by following the pipeline 'SampleData[JoinedSequencesWithQuality] with the source format SingleEndFastqManifestPhred33.
The problem is that I cannot construct a manifest file in which I put each sample below the column sample-id with the corresponding absolute filepath because I do not have a single fastaq file for each sample. So, I tried the same by putting each one of the 4 files I have below the column sample-id, each one with its corresponding format, but the format is not recognized by qiime.
Could someone give me some ideas on how to generate a proper manifest file in my case?
Thank you very much!
Serena

1 Like

Hello Serena,

Welcome to the forums! Let me see if I can help you get started.

I have 4 fastaq files each one containig 48 samples

So a total of 192 samples, with 48 samples in each fastq file? How are they multiplexed? Could qiime demux emp-single work for you, being run on each of your four 4 fastq files?
https://docs.qiime2.org/2019.7/tutorials/moving-pictures/#demultiplexing-sequences

Colin

A post was split to a new topic: How to import demultiplexed .fna files into QIIME 2?

Hi Colin,

thank you very much for the reply and sorry to answer you only now but I didn’t have access to the sotware. I have just tried the procedure you suggested me, but I am stucked in the importingfile step. In order to demultiplex sequences I need to convert my fastq file in qza and for it I would also need a barcodes.fastq.gz file which I don’t have.

Serena

1 Like

Hello Serena,

There are many different ways to import data! Let’s see if we can find a method that will work well for you.

If your barcodes are in a separate barcodes.fastq.gz file, you do. But if your barcodes are inside the same FASTQ file, you could try using the cutadapt plugin.
https://docs.qiime2.org/2019.7/plugins/available/cutadapt/demux-single/

Let me know if you think that’s a good fit for your data.

Colin

Hi Colin!! thank you very much for your suggestion!!
I tried the cutadapt plugin and it worked. It generated me an untrimmed.qza file. Nonetheless when I tried to summarize demultiplexed reads and generated a .qzv file it gave me this error:

Plugin error from demux
Argument to parameter ‘data’ is not a subtype of SampleData[JoinedSequencesWithQuality | PairedEndSequencesWithQuality | SequencesWithQuality].

There is another way to visualize the results obtained from demultiplexing and/or maybe to convert my demultiplexed reads in fastq files?

Serena

Hello Serena,

What command did you run? Any other outputs or clues about what could have went wrong?

Colin

I’ve used the following script after obtaining the untrimmed.qza file:

qiime demux summarize --i-data untrimmed.qza --o-visualization trimmed-seqs_xip2.qzv.

I know that my data do not correspond exactly with any of the format suggested my this command, because they include single end sequences wich could be forward or reverse reads that are neither paired nor joined, so maybe this could be the problem. I have seen in the forum that other people using data from Ion Torrent pipeline used to treat them like JoinedSequencesWithQuality, but maybe in my case I get errors. I really don’t know how to solve this problem.

I’m sure about the exact commands that will work for your data, but I know the the direction we should go.

Let’s work backwards.

Argument to parameter ‘data’ is not a subtype of SampleData[JoinedSequencesWithQuality | PairedEndSequencesWithQuality | SequencesWithQuality].

OK, so we need to use one of these types. Given that you only have forward reads, I think
SampleData[SequencesWithQuality]
is probably the best option.

So now that we know the desired data type of --i-data, we can make this file again, now with the proper data type.

I think qiime cutadapt demux-single will output an artifact with SampleData[SequencesWithQuality]

Wait! How did you make untrimmed.qza? If you have not tried cutadapt demux-single yet, now it a great time to try it, because I think it will make the exact data type you are looking for.


Edit: Have you discovered the q2-cutadapt community tutorial? You should totally check that out!

Colin

Yes I have used q2-cutadapt plugin. It has just worked, I had put the wrong input path in the script to obtain the .qzv file.
Now I have also tried to extract the .qzv file in a feature table which gave me the information of the demultiplexing process, but is there a way to obtain the demultiplexed samples each one in a .fastq format before proceeding with denoising step?

1 Like

Oh good!

Yes. The .qza files are just .zip files with a fancy name, so you can rename it to .zip and unzip the archive using your favorite program. On Linux and OSX I use unzip filename.zip and on Windows I just double-click to open. You will find all your fastq.gz files for each sample in the data/ folder of the extracted .qza file.

Of course, the denoising step needs the .qza file, so you don’t have to extract at all.

Colin

Yes it worked perfectly!! many thanks for your help. The point is that I would like somehow to analyze first each fastaq in order to separate the reads from different hypervariable regions of 16S which I have in each fastaq file, that’s why I think I cannot go ahead with denoising step.

Thank you very much!!

Serena

Hello Serena,

Yes, that makes sense. You will have to process each separate region separately!

I’m not totally familiar with the Ion Torrent primers, but I worry the different regions might be mixed together into the same fastq file. But you are probably more familiar with this primer set than I am.

Colin