"Invalid value for 'input-path'

Hello friend. I am currently having the same problem importing the files even though I have it in my folder.
I am new to using Qiime2, but at the time of placing the command:
qiime tools import
--type 'SampleData[SequencesWithQuality]'
--input-path data/manifest.tsv
--output-path sequences.qza
--input-format SingleEndFastqManifestPhred33V2
I get an error:


I already tried with another tutorial and I got the same error you got.
Please help!

By the way, I'm doing this tutorial: https://github.com/Gibbons-Lab/isb_course_2023/tree/main/treasure_chest

Hi @WILLIAM_GUILLERMO_VI,
Are you on a HPC or cluster? Sometimes managed super computers have different permissions. That was this original posters issue, and the next course of action is to reach out to your HPC team!

Otherwise, Can you please ls data/ so we can confirm that the data directory does have the manifest in it.

1 Like

I have been looking at many ways and I get this problem:


I've been updating, but nothing.

If you're on a computer cluster you have to talk to the IT folks for the cluster to get the correct path. I had my directories set up as /projects/PIname/mkc206/MetaData/FileFolder, which would populate when I used ls, but the IT people had me use the path /lustre6/project/mkc206/MetaData/FileFolder. Then on a different server I have to drop the /lustre6/. Keep in mind I have no folder by that name, and I really do have to use "project" instead of "projects".

Anyway, it really cannot be predicted what the path should be and you just have to contact support for you server. If you are not on a server then I unfortunately don't have the answer. Good luck!

4 Likes

Hi @WILLIAM_GUILLERMO_VI,

@mkc206. Thanks for the Great explaination of how to debug a cluster permissions error. I have nothing to add if @WILLIAM_GUILLERMO_VI is on a cluster!

From your error message file paths, I'm guessing you are on your own laptop, is that correct?

It seems like from both codes snips your code are failing because it can not find the data you are looking for.

Have you made sure to download the tutorial code before starting this tutorial? All that info on downloading the data will be in the READ_ME of the github repo: GitHub - Gibbons-Lab/isb_course_2023: Materials and presentation for the 2023 ISB Microbiome course.

1 Like

Thank you so much @mkc206. I will try to communicate the IT :hugs:

Hi @cherman2,
Yes, my problem. My problem is with my computer. I have done all the steps in the tutorial and I can import data as normal. But the only problem is importing data with the terminal on my computer. The funny thing is that I only have problems with the script
qiime tools import
--type "SampleData[PairedEndSequencesWithQuality]"
--path-input-path Sample_man_new.csv
--output-path Sample_man_new.qza
--input-format PairedEndFastqManifestPhred33

Another script, everything is perfect.

Hi @WILLIAM_GUILLERMO_VI,
I am getting alittle lost. I think there are too many things going on. So lets take a small step back.

Both of your above errors seem to say that those files (data/manifest.tsv, and setup_qiime2.py) don't exist or at least don't exist where you think they do.

Can you post the full command that you are running and getting errors on?

2 Likes

Hi @cherman2,
Here is my working directory:


When I run the script, I get the following description:

I think the problem is here, friend. I want to use pandas in Qiime2, but I don't know how to do it. In the tutorial, they do that step.

I don't know how to run panda in Qiime2.

1 Like

Hi @WILLIAM_GUILLERMO_VI,
Looking at your original command vs the command you just posted. It seems like you discovered your original error. Originally, you pointed at the manifest in "data/manifest.tsv" but the manifest seems to be in your working directory. Awesome! :+1: One error Down!

Now we have a different error coming out of your import command :scream:

This one says that the absolute file path that you provide for your sample ERR1883195 could not be found "$PWD/data/ERR1883195.fastq.qz"

I can not tell what your working directory is named but if it is not data, you may fall victim to the same issue as with the manifest file in your original command. You are telling your computer that the filepath is $PWD/data/ERR1883195.fastq.qz but if that file path is not correct, it wont be able to find your data. Please double check that the absolute path in the manifest is pointing to the location which your data is stored.

Additionally, do you have a environment variable named $PWD? If you do not have a environment variable named $PWD, then again there will be no way for the computer to understand where the start of your file path is. Please confirm that you have the environment variable $PWD set.

Here is our docs on importing with a manifest file: Importing data — QIIME 2 2023.9.2 documentation. These might help you better understand how the manifest file is working. Please read though the manifest portion of the docs before your next reply

I disagree that this is a pandas problem. But I would need more info to be sure. According to the text above the code cell and the code itself, you are using pandas to view the manifest. Very similar to running nano/vim manifest.tsv. I cant see the output of this code block, Did it fail?

For future responses to this post, Could you try to focus more on directly addressing the questions asked? It would greatly assist in providing accurate and effective support, allowing us to work towards a solution more efficiently.

I hope this helps!
:turtle:

2 Likes

Well shucks. Thanks for the response. I’ll see what I can do to get it imported.
Thanks for the help!

Hi @cherman2 (Again),
I saw what the mistake was.
In the video where they explain the tutorial(https://github.com/Gibbons-Lab/isb_course_2023/tree/main/treasure_chest) , they mention that they do not give the dexmultiplexed file. Unfortunately, with those files I cannot perform the following steps on my work source.
I corroborated it, because I did the tutorial from the same page QIIME2, and I get the script normally.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.