Invalid value for '--i-table': './table.qza' is not a QIIME 2 Artifact (.qza)?

It is an old question repeatedly asked in our forum. I have tried with updated qiime2 2021.11 and adding / or ./ to code. Their result is the same error.

I tried the different table.qza and failed, could you suggest a way to overcome this error?

Hi @Wang_cs001632,

I suspect there is something wrong with your table.qza file - let's run a test to find out!

Please try running this command (in the same directory as your table.qza file) and copy/paste the output in your response.

zip -T table.qza

Thanks! :lizard:

Hi! I'm not sure if this has been solved yet or not, but I think I ran into something similar a while back. For me, I found that the problem lay in the ./ section of "./table.qza". For some reason, I had to list out the whole directory path (not sure if that's the right terminology), e.g. "/users/ChenJo/querying_redbiom/analysis/table.qza"

Hope this helps!

*edit: sorry just realized that I replied to the helper, not the original topic! edited now

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.