Invalid value for ‘–i-classifier’: ‘silva-138-99-515-806-nb-classifier.qza’ is not a QIIME 2 Artifact (.qza)

Hi! I have the same error. I can successfully perform the classification with “gg-13-8-99-515-806-nb-classifier.qza”; however, if I run the same command with “silva-138-99-515-806-nb-classifier.qza” the following error is shown:

There was a problem with the command:
(1/1) Invalid value for ‘–i-classifier’: ‘silva-138-99-515-806-nb-classifier.qza’ is not a QIIME 2 Artifact (.qza)

This is the command I used:

qiime feature-classifier classify-sklearn
–i-classifier gg-13-8-99-515-806-nb-classifier.qza
–i-reads rep-seqs.qza
–o-classification taxonomy.qza

I have all files in the same folder and I also have enough free space (<300 Gb) in my hard disk. I donwloaded the SILVA database from the QIIME2 website.

Can you help me?

Thanks

Hi @Humberto_Aponte!

What version of QIIME 2 are you running? If you aren’t running 2020.8, can you upgrade to it and try again? Keep us posted!

:qiime2:

Hi @thermokarst,

I used the 2020.6 on Windows Subsystem Linux (maybe that´s the problem), I will try again with the new version :slight_smile:

Thanks!

1 Like