Interpretation of interactive plot to determine trim length in Deblur

Dear colleagues, I am still new to QIIME2 and I am following the online tutorials. I would like to denoise my joined paired-end sequences but I am struggling to understand how to figure out the trim-length value when I run this command:
qiime deblur denoise-16S
–i-demultiplexed-seqs demux-joined-filtered.qza
–p-trim-length 250
–p-sample-stats
–o-representative-sequences rep-seqs.qza
–o-table table.qza
–o-stats deblur-stats.qza

Following the tutorial here, Alternative methods of read-joining in QIIME 2 — QIIME 2 2021.2.0 documentation, this value has to be determined using the quality plot generated from Vsearch (see here, QIIME 2 View) but I am failing to grasp how the 250 was determined. In other words, I am failing to interpret the plot to determine the length of the sequences.
When I tried to run my own data, I figured out the length may be 290 (of which I think I misinterpreted the quality plot) but when I tried to view the feature table using the following command, I got zeros and nans meaning there was nothing in the table:
qiime feature-table summarize
–i-table rep-table.qza
–o-visualization rep-table.qzv


What could be the problem?
Please help.

Hello @BlessingMhlanga,
So the quality plot is a bunch box plot of the quality of your sequences at every single nucleotide. This allows you to see where the quality of your sequences overall and at specific nucleotides. Basically what you are looking for ( although this isn’t a rule its a suggestion) is a median quality scores around or above 30.

If you look at the interactive quality plot for the tutorial you can see that there is this sudden drop in quality around 250. I suspect that that is why they decided to trim at that point. When coming up with a trim parameter you want to make sure that there is not too much noise for the quality control to sort through so I typically trim before a drop off in quality. I hope this helps you understand how to interpret interactive quality plot.

You problem might be that you trimmed at the wrong spot. Without seeing your interactive plot I cant really speak on why you didn’t get any samples into your feature table. However if you want to upload your demux.qzv I would be happy to take a look.

Hope this helps!
Chloe :turtle:

Hello Chloe,

Thank you very much for your explanation. I somehow understood how it works. I attach another .qzv file from my own data which we can use as an example to see if I understood. So, would it be correct to trim at 324 for this attached example?

Cheers,

BlessingYORK-demux-joined (copy).qzv (303.8 KB)

Hello @BlessingMhlanga ,
I don’t see anything in your demux file that suggests you did anything wrong selecting your trim length. I thought that your sequences might have been too short for your chosen trim length but I don’t think that is the case.

I think you could reasonably trim at 324, or maybe even further back without a problem. Your sequences look like they are good quality. I would try using 324 and if still no samples make it through the deblur filter. Then the next step would be to look at your deblur-stats.qza (you will have to turn it into a .qzv to view it) and see if there is one step were you lose all your reads. This is helpful because you can see every step of the filtering process and it will give you a better idea where these sequences are getting stuck.

I hope this helps!
Chloe :turtle:

1 Like