Interactive plots not working

after upgrading to QIIME 2 2017.11 interactive plots are not working anymore. For example, in demux.qzv (obtained from my data) I can see Overview, but Interactive Quality Plot is completely empty. I tried alpha rarefaction with Moving pictures tutorial data and got the same problem.
Did anyone have the same problem or has a suggestion how to solve it?
Thank you in advance!

Hi @vjera, sorry to hear things aren’t going well. It would be helpful if we could get a bit more information to help us get to the bottom of this:

  • How are you looking at these visualizations? Are you using Or, are you using qiime tools view?
  • Can you view visualizations you created with previous versions of QIIME 2?
  • Have you tried with the latest release, 2017.12?
  • What browser and version are you using to view?
  • Can you send us some screenshots of one of the impacted visualizations? Can you share one of the visualizations (.qzv)?

Thanks! :t_rex:

Thank you for your quick reply!

I'm using because qiime tools view always freezes for some reason.
Yes, previously I had 2017.7 and the visualisations were working fine.
No, at our institute we got installed 2017.11 just few weeks ago.
I'm using Google Chrome: 63.0.3239.84 (Offizieller Build) (64-Bit) (cohort: Stable)

I have sent one of the .qzv files to a colleague to check if it can be viewed on different qiime2 version and different browser, but the problem remained.

demux.qzv (208.3 KB)

Thank you!

1 Like

Hi @vjera! Thanks for following up, the provenance in your Visualization was super helpful:

28 PM

Something jumped out immediately at me - we don't support python 3.6 yet, and our official Native Install docs use a conda environment file that ensures that python 3.5 is installed in your QIIME 2 environment. If I had to guess, it looks like this is a source install that your institution is using, which unfortunately is not an installation mechanism that we can provide support for. The other piece of evidence suggesting that this is a source install is how your demux summarize viz is failing --- you are missing some javascript assets that are built out as part of the conda build process. If this was a conda install, those files would be there.

Is your institution unable to use conda?

Thanks! :t_rex:

So, I've asked about conda... :confused: Here's the answer:
"Dear Vjera,

i can not use conda, because we do a cluster installation

on rpm files on sles 11 SP2. And we can not install

the operating system they use, because a lot of more software

run on this environment and usage of conda will destroy

the usage of the cluster. And only if the same system

is used and only qiime2 run on it, then conda is possible.

To decide only to provide an running conda installation is

for such a project normaly a criteria to never use this in HPC

or cluster environment or on any other machine. No source

help is a joke.

I do not use python 3.5 because on my opinion this is a

dead release. Most distributions usind 3.4 and then 3.6 on opensuse

leap 42 use 3.4 and leap 15 goes to 4.6 same with sles 11 SP2 which

do not have python3 and i installed therefore the versions given by


If from source installation missing some javascript needed, then they have to

provide them and not only for conda installation. Because if not the

complete source code on the repository can be forgotten.

The source code also says nothing about dependencies between the

qiime2 packages. I could laugh, but it is for crying.

On generating rpm i run the examples on each package and it shows,

that not python 3.6 is the problem, its the qiime2 coding which

have significant problems, run in 07 do not run in 11.

The problem here is libssu from

and from my hard i needed two weeks to get it run and it was the

biggest "shit" module ever seen for python."

Thanks for following up, @vjera! Sorry to hear that conda isn’t a viable option for your institution, we have heard many success stories, but we understand that it isn’t a 100% fit for everyone! Some options moving forward:

  • Can you institutional cluster leverage Docker containers? We provide an official docker image that is built and tested with each release.
  • If your cluster sysadmin would like to pursue a source-based install, they are welcome to get in touch with us here on the forum, we can provide some pointers to hopefully answer their questions about our build and deployment strategy. A quick note, we generally don’t provide end-user support for a source install because it is a monumental task. There are about 200 dependencies, spanning Python, R, javascript, and many other languages and runtimes, and getting all of these things to talk to each other in a coherent and consistent manner is not a trivial task. The conda environment provides a convenient tool for us to help facilitate that process, but we recognize that it isn’t always the best solution for everyone, and to that end we will continue to consider our options, and would love to hear from your sysadmin on some of the institution’s constraints!
  • Will your sysadmin allow you to install conda within your own user account on the cluster? This is another common use case that we have seen many times — if you are allowed to install your own software within your home directory, you can follow the Native Install docs to make that happen (please check with your sysadmin first!).
  • If your institutional cluster is ultimately a resource that you will not be able to run QIIME 2 on, are you able to install locally on your own workstation? If you are on a mac or linux machine, you could run a native install, and if not, you could use one of our virtual machines.
  • If none of those options are available to you, we also provide an official Amazon Web Services AMI, which you could use (amazon charges might be applicable).

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.