installing Qiime2 with mamba

I tried to install qiime2-2021.11-py38-linux-conda.yml with mamba and got this error:

mamba env create -n qiime2-2021.11 --file qiime2-2021.11-py38-linux-conda.yml


Encountered problems while solving.
Problem: nothing provides __glibc >=2.17,<3.0.a0 needed by nodejs-16.12.0-h73e1104_0
Problem: nothing provides __glibc >=2.17,<3.0.a0 needed by nodejs-16.12.0-h73e1104_0

I do not get this error with conda. :snail:

The mamba installer is much faster than conda's and is the default in snakemake. Any advice about why this is failing would be very helpful!


In my experience, such an error occurs due to dependency mismatch caused by installing apps from wrong channels in conda.
Try to add bioconda and conda-forge to default channels via:

conda config --add channels bioconda
conda config --add channels conda-forge


add a channel specification in qiime2-2021.11-py38-linux-conda.yml:

- defaults
- conda-forge
- bioconda

Tested QIIME2 2021.11 installation 5h ago on a fresh VM via mamba. All worked smoothly by me without need to modify anything.


Thanks for the advice!

Those channels are already at the top of the .yml file:

(snakemake) [[email protected] envs]$ head qiime2-2021.11-py38-linux-conda.yml 
  - qiime2/label/r2021.11
  - conda-forge
  - bioconda
  - defaults

Very interesting!

Here's my software versions. I wonder if the online database changed earlier today and we are the first to notice...

(base) [[email protected] envs]$ mamba --version
mamba 0.7.5
conda 4.11.0
1 Like

Okay, now I see.
You have the wrong version of mamba :slight_smile:
0.7.5 is actually older and it doesn't respect channels in .yml
The latest release is 0.19.1.
They underwent some reversioning IDK.

My stack:

mamba 0.19.1
conda 4.11.0

That did it!

Thank you for your help, Valentyn.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.