installing qiime2 into windows 11

I am having trouble installing QIIME2 into Windows 11 with conda. I used the commands from the QIIME2 website:
wget https://data.qiime2.org/distro/amplicon/qiime2-amplicon-2024.5-py38-linux-conda.yml
conda env create -n qiime2-amplicon-2024.5 --file qiime2-amplicon-2024.5-py38-linux-conda.yml
I got the a long error message:
Could not solve for environment specs
The following packages are incompatible
├─ _openmp_mutex 4.5** is installable and it requires
│ └─ msys2-conda-epoch <0.0a0 , which can be installed;
├─ _r-mutex 1.0.1** is requested and can be installed;
├─ alsa-lib 1.2.11** does not exist (perhaps a typo or a missing channel);
├─ attr 2.5.1** does not exist (perhaps a typo or a missing channel);
├─ binutils_impl_linux-64 2.40** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-ancombc 2.4.0** is not installable because it requires
│ └─ bioconductor-s4vectors >=0.40.0,<0.41.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-beachmat 2.18.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-biobase 2.62.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-biocbaseutils 1.4.0** is not installable because it requires
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ bioconductor-biocgenerics 0.48.1** is not installable because it requires
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ bioconductor-biocneighbors 1.20.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-biocparallel 1.36.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-biocsingular 1.18.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-biomformat 1.30.0** is not installable because it requires
│ └─ bioconductor-rhdf5 >=2.46.0,<2.47.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-biostrings 2.70.1** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-bluster 1.12.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-dada2 1.30.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-decipher 2.30.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-decontam 1.22.0** is not installable because it requires
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ bioconductor-delayedarray 0.28.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-delayedmatrixstats 1.24.0** is not installable because it requires
│ └─ bioconductor-delayedarray >=0.28.0,<0.29.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-dirichletmultinomial 1.44.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-genomeinfodb 1.38.1** is not installable because it requires
│ └─ bioconductor-iranges >=2.36.0,<2.37.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-genomeinfodbdata 1.2.11** is not installable because it requires
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ bioconductor-genomicalignments 1.38.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-genomicranges 1.54.1** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-iranges 2.36.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-matrixgenerics 1.14.0** is not installable because it requires
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ bioconductor-mia 1.10.0** is not installable because it requires
│ └─ bioconductor-biocparallel >=1.36.0,<1.37.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-multiassayexperiment 1.28.0** is not installable because it requires
│ └─ bioconductor-biobase >=2.62.0,<2.63.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-multtest 2.58.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-phyloseq 1.46.0** is not installable because it requires
│ └─ bioconductor-biobase >=2.62.0,<2.63.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-rhdf5 2.46.1** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-rhdf5filters 1.14.1** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-rhdf5lib 1.24.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-rhtslib 2.4.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-rsamtools 2.18.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-s4arrays 1.2.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-s4vectors 0.40.2** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-scaledmatrix 1.10.0** is not installable because it requires
│ └─ bioconductor-delayedarray >=0.28.0,<0.29.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-scater 1.30.1** is not installable because it requires
│ └─ bioconductor-beachmat >=2.18.0,<2.19.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-scuttle 1.12.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-shortread 1.60.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-singlecellexperiment 1.24.0** is not installable because it requires
│ └─ bioconductor-delayedarray >=0.28.0,<0.29.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-sparsearray 1.2.2** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-sparsematrixstats 1.14.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-summarizedexperiment 1.32.0** is not installable because it requires
│ └─ bioconductor-biobase >=2.62.0,<2.63.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-treeio 1.26.0** is not installable because it requires
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ bioconductor-treesummarizedexperiment 2.10.0** is not installable because it requires
│ └─ bioconductor-biocparallel >=1.36.0,<1.37.0 , which does not exist (perhaps a missing channel);
├─ bioconductor-xvector 0.42.0** does not exist (perhaps a typo or a missing channel);
├─ bioconductor-zlibbioc 1.48.0** does not exist (perhaps a typo or a missing channel);
├─ blast 2.15.0** does not exist (perhaps a typo or a missing channel);
├─ bowtie2 2.5.4** does not exist (perhaps a typo or a missing channel);
├─ cutadapt 4.8** does not exist (perhaps a typo or a missing channel);
├─ dbus 1.13.6** does not exist (perhaps a typo or a missing channel);
├─ deblur 1.1.1** is not installable because it requires
│ └─ mafft >=7.394 , which does not exist (perhaps a missing channel);
├─ dnaio 1.2.0** does not exist (perhaps a typo or a missing channel);
├─ emperor 1.0.4** does not exist (perhaps a typo or a missing channel);
├─ entrez-direct 21.6** does not exist (perhaps a typo or a missing channel);
├─ fasttree 2.1.11** does not exist (perhaps a typo or a missing channel);
├─ gawk 5.3.0** does not exist (perhaps a typo or a missing channel);
├─ gcc_impl_linux-64 13.2.0** does not exist (perhaps a typo or a missing channel);
├─ gfortran_impl_linux-64 13.2.0** does not exist (perhaps a typo or a missing channel);
├─ gmp 6.3.0** is installable and it requires
│ └─ mpir <0.0a0 , which can be installed;
├─ gxx_impl_linux-64 13.2.0** does not exist (perhaps a typo or a missing channel);
├─ hmmer 3.1b2** does not exist (perhaps a typo or a missing channel);
├─ htslib 1.20** does not exist (perhaps a typo or a missing channel);
├─ iow 1.0.5** does not exist (perhaps a typo or a missing channel);
├─ iqtree 2.3.4** does not exist (perhaps a typo or a missing channel);
├─ jq 1.7.1** does not exist (perhaps a typo or a missing channel);
├─ keyutils 1.6.1** does not exist (perhaps a typo or a missing channel);
├─ ld_impl_linux-64 2.40** does not exist (perhaps a typo or a missing channel);
├─ libcap 2.69** does not exist (perhaps a typo or a missing channel);
├─ libclang-cpp15 15.0.7** does not exist (perhaps a typo or a missing channel);
├─ libcups 2.3.3** does not exist (perhaps a typo or a missing channel);
├─ libedit 3.1.20191231** does not exist (perhaps a typo or a missing channel);
├─ libev 4.33** does not exist (perhaps a typo or a missing channel);
├─ libgcc-ng 13.2.0** does not exist (perhaps a typo or a missing channel);
├─ libgcrypt 1.10.3** does not exist (perhaps a typo or a missing channel);
├─ libgfortran-ng 13.2.0** does not exist (perhaps a typo or a missing channel);
├─ libgfortran5 13.2.0** is installable and it requires
│ ├─ libwinpthread >=12.0.0.r2.ggc561118da , which requires
│ │ └─ msys2-conda-epoch <0.0a0 , which can be installed;
│ └─ msys2-conda-epoch <0.0a0 , which can be installed;
├─ libgomp 13.2.0** is installable and it requires
│ └─ msys2-conda-epoch <0.0a0 , which can be installed;
├─ libgpg-error 1.49** does not exist (perhaps a typo or a missing channel);
├─ libidn2 2.3.7** does not exist (perhaps a typo or a missing channel);
├─ libnsl 2.0.1** does not exist (perhaps a typo or a missing channel);
├─ libsanitizer 13.2.0** does not exist (perhaps a typo or a missing channel);
├─ libstdcxx-ng 13.2.0** does not exist (perhaps a typo or a missing channel);
├─ libsystemd0 255** does not exist (perhaps a typo or a missing channel);
├─ libunistring 0.9.10** does not exist (perhaps a typo or a missing channel);
├─ libuuid 2.38.1** does not exist (perhaps a typo or a missing channel);
├─ libxcrypt 4.4.36** does not exist (perhaps a typo or a missing channel);
├─ libxkbcommon 1.7.0** does not exist (perhaps a typo or a missing channel);
├─ mafft 7.520** does not exist (perhaps a typo or a missing channel);
├─ mpfr 4.2.1** is not installable because it requires
│ └─ mpir >=3.0.0,<4.0a0 , which conflicts with any installable versions previously reported;
├─ ncbi-vdb 3.1.1** does not exist (perhaps a typo or a missing channel);
├─ ncurses 6.5** does not exist (perhaps a typo or a missing channel);
├─ nspr 4.35** does not exist (perhaps a typo or a missing channel);
├─ nss 3.100** does not exist (perhaps a typo or a missing channel);
├─ pandoc 3.2** is requested and can be installed;
├─ pbzip2 1.1.13** does not exist (perhaps a typo or a missing channel);
├─ perl-archive-tar 2.40** is not installable because it requires
│ └─ perl >=5.32.1,<6.0a0 _perl5, which does not exist (perhaps a missing channel);
├─ perl-carp 1.50
* is not installable because it requires
│ └─ perl >=5.32.1,<6.0a0 _perl5, which does not exist (perhaps a missing channel);
├─ perl-common-sense 3.75
* is not installable because it requires
│ └─ perl >=5.32.1,<6.0a0 _perl5, which does not exist (perhaps a missing channel);
├─ perl-compress-raw-bzip2 2.201
* does not exist (perhaps a typo or a missing channel);
├─ perl-compress-raw-zlib 2.202** does not exist (perhaps a typo or a missing channel);
├─ perl-encode 3.21** does not exist (perhaps a typo or a missing channel);
├─ perl-exporter-tiny 1.002002** is not installable because it requires
│ └─ perl >=5.32.1,<6.0a0 _perl5, which does not exist (perhaps a missing channel);
├─ perl-exporter 5.74
* is not installable because it requires
│ └─ perl >=5.32.1,<6.0a0 _perl5, which does not exist (perhaps a missing channel);
├─ perl-extutils-makemaker 7.70
* is not installable because it requires
│ └─ perl >=5.32.1,<6.0a0 _perl5, which does not exist (perhaps a missing channel);
├─ perl-io-compress 2.201
* does not exist (perhaps a typo or a missing channel);
├─ perl-io-zlib 1.14** is not installable because it requires
│ └─ perl >=5.32.1,<6.0a0 _perl5, which does not exist (perhaps a missing channel);
├─ perl-json-xs 2.34
* does not exist (perhaps a typo or a missing channel);
├─ perl-json 4.10** is not installable because it requires
│ └─ perl >=5.32.1,<6.0a0 _perl5, which does not exist (perhaps a missing channel);
├─ perl-list-moreutils-xs 0.430
* does not exist (perhaps a typo or a missing channel);
├─ perl-list-moreutils 0.430** is not installable because it requires
│ └─ perl >=5.32.1,<6.0a0 _perl5, which does not exist (perhaps a missing channel);
├─ perl-parent 0.241
* is not installable because it requires
│ └─ perl >=5.32.1,<6.0a0 _perl5, which does not exist (perhaps a missing channel);
├─ perl-pathtools 3.75
* does not exist (perhaps a typo or a missing channel);
├─ perl-scalar-list-utils 1.63** does not exist (perhaps a typo or a missing channel);
├─ perl-storable 3.15** does not exist (perhaps a typo or a missing channel);
├─ perl-types-serialiser 1.01** is not installable because it requires
│ └─ perl >=5.32.1,<6.0a0 _perl5, which does not exist (perhaps a missing channel);
├─ pulseaudio-client 17.0
* does not exist (perhaps a typo or a missing channel);
├─ q2-alignment 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-composition 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-cutadapt 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-dada2 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-deblur 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-demux 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-diversity-lib 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-diversity 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-emperor 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-feature-classifier 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-feature-table 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-fragment-insertion 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-longitudinal 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-metadata 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-mystery-stew 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-phylogeny 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-quality-control 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-quality-filter 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-sample-classifier 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-taxa 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-types 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2-vsearch 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2cli 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2galaxy 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ q2templates 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ qiime2 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ r-base 4.3.3** does not exist (perhaps a typo or a missing channel);
├─ r-bh 1.84.0_0** is not installable because there are no viable options
│ ├─ r-bh 1.84.0_0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-bh 1.84.0_0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-boot 1.3_30** is not installable because there are no viable options
│ ├─ r-boot 1.3_30 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-boot 1.3_30 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-broom 1.0.6** is not installable because there are no viable options
│ ├─ r-broom 1.0.6 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-broom 1.0.6 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-bslib 0.7.0** is not installable because there are no viable options
│ ├─ r-bslib 0.7.0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-bslib 0.7.0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-callr 3.7.6** is not installable because there are no viable options
│ ├─ r-callr 3.7.6 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-callr 3.7.6 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-codetools 0.2_20** is not installable because there are no viable options
│ ├─ r-codetools 0.2_20 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-codetools 0.2_20 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-curl 5.1.0** does not exist (perhaps a typo or a missing channel);
├─ r-data.table 1.15.2** is not installable because it requires
│ └─ m2w64-zlib, which requires
│ └─ msys2-conda-epoch [20160418 |>=20160418 ], which conflicts with any installable versions previously reported;
├─ r-dbi 1.2.2** is not installable because there are no viable options
│ ├─ r-dbi 1.2.2 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-dbi 1.2.2 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-dbplyr 2.5.0** is not installable because there are no viable options
│ ├─ r-dbplyr 2.5.0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-dbplyr 2.5.0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-desctools 0.99.54** does not exist (perhaps a typo or a missing channel);
├─ r-evaluate 0.23** is not installable because there are no viable options
│ ├─ r-evaluate 0.23 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-evaluate 0.23 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-fontawesome 0.5.2** is not installable because there are no viable options
│ ├─ r-fontawesome 0.5.2 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-fontawesome 0.5.2 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-frictionless 1.1.0** is not installable because there are no viable options
│ ├─ r-frictionless 1.1.0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-frictionless 1.1.0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-gargle 1.5.2** is not installable because there are no viable options
│ ├─ r-gargle 1.5.2 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-gargle 1.5.2 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-gbrd 0.4.12** is not installable because there are no viable options
│ ├─ r-gbrd 0.4.12 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-gbrd 0.4.12 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-getopt 1.20.4** is not installable because there are no viable options
│ ├─ r-getopt 1.20.4 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-getopt 1.20.4 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-ggplot2 3.5.1** is not installable because there are no viable options
│ ├─ r-ggplot2 3.5.1 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-ggplot2 3.5.1 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-googledrive 2.1.1** is not installable because there are no viable options
│ ├─ r-googledrive 2.1.1 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-googledrive 2.1.1 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-googlesheets4 1.1.1** is not installable because there are no viable options
│ ├─ r-googlesheets4 1.1.1 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-googlesheets4 1.1.1 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-gtable 0.3.5** is not installable because there are no viable options
│ ├─ r-gtable 0.3.5 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-gtable 0.3.5 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-highr 0.11** is not installable because there are no viable options
│ ├─ r-highr 0.11 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-highr 0.11 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-hmisc 5.1_3** is installable and it requires
│ └─ r-rmarkdown with the potential options
│ ├─ r-rmarkdown [2.14|2.17|...|2.27] would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ ├─ r-rmarkdown [2.22|2.23|...|2.27] would require
│ │ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
│ ├─ r-rmarkdown [1.10|1.11|...|2.9] would require
│ │ └─ pandoc [>=1.12.3,<3.0 |>=1.14,<3.0 ], which conflicts with any installable versions previously reported;
│ ├─ r-rmarkdown [1.2|1.3|1.5|1.6] would require
│ │ └─ r-base 3.3.2* , which can be installed;
│ ├─ r-rmarkdown 1.6 would require
│ │ └─ pandoc <2.0 , which conflicts with any installable versions previously reported;
│ ├─ r-rmarkdown [1.5|1.6] would require
│ │ └─ r-base 3.4.1* , which can be installed;
│ ├─ r-rmarkdown 0.5.1 would require
│ │ └─ r-base 3.1.3* , which does not exist (perhaps a missing channel);
│ ├─ r-rmarkdown 0.9.5 would require
│ │ └─ r-base 3.2.4* , which does not exist (perhaps a missing channel);
│ ├─ r-rmarkdown 0.9.6 would require
│ │ └─ r-base 3.3.0* , which can be installed;
│ ├─ r-rmarkdown [0.9.6|1.2] would require
│ │ └─ r-base 3.3.1* , which can be installed;
│ ├─ r-rmarkdown [1.10|1.8] would require
│ │ └─ _r-mutex 1.* mro_2, which conflicts with any installable versions previously reported;
│ ├─ r-rmarkdown 1.10 would require
│ │ └─ r-base >=3.5.1,<3.5.2.0a0 , which can be installed;
│ ├─ r-rmarkdown 1.6 would require
│ │ └─ r-base >=3.4.2,<3.4.3a0 , which can be installed;
│ ├─ r-rmarkdown 1.8 would require
│ │ └─ r-base >=3.4.3,<3.4.4.0a0 , which can be installed;
│ └─ r-rmarkdown 1.12 would require
│ └─ r-base >=3.6,<3.7.0a0 , which can be installed;
├─ r-htmltable 2.4.2** is not installable because there are no viable options
│ ├─ r-htmltable 2.4.2 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-htmltable 2.4.2 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-htmlwidgets 1.6.4** is not installable because there are no viable options
│ ├─ r-htmlwidgets 1.6.4 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-htmlwidgets 1.6.4 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-httr 1.4.7** is not installable because there are no viable options
│ ├─ r-httr 1.4.7 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-httr 1.4.7 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-igraph 2.0.3** does not exist (perhaps a typo or a missing channel);
├─ r-knitr 1.46** is not installable because there are no viable options
│ ├─ r-knitr 1.46 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-knitr 1.46 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-labeling 0.4.3** is not installable because there are no viable options
│ ├─ r-labeling 0.4.3 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-labeling 0.4.3 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-lifecycle 1.0.4** is not installable because there are no viable options
│ ├─ r-lifecycle 1.0.4 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-lifecycle 1.0.4 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-mass 7.3_60** does not exist (perhaps a typo or a missing channel);
├─ r-multcomp 1.4_25** is not installable because there are no viable options
│ ├─ r-multcomp 1.4_25 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-multcomp 1.4_25 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-munsell 0.5.1** is not installable because there are no viable options
│ ├─ r-munsell 0.5.1 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-munsell 0.5.1 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-nloptr 2.0.3** is not installable because it requires
│ └─ m2w64-nlopt, which requires
│ └─ msys2-conda-epoch [20160418 |>=20160418 ], which conflicts with any installable versions previously reported;
├─ r-openssl 2.2.0** does not exist (perhaps a typo or a missing channel);
├─ r-optparse 1.7.5** is not installable because there are no viable options
│ ├─ r-optparse 1.7.5 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-optparse 1.7.5 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-pixmap 0.4_13** is not installable because there are no viable options
│ ├─ r-pixmap 0.4_13 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-pixmap 0.4_13 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-prettyunits 1.2.0** is not installable because there are no viable options
│ ├─ r-prettyunits 1.2.0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-prettyunits 1.2.0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-progress 1.2.3** is not installable because there are no viable options
│ ├─ r-progress 1.2.3 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-progress 1.2.3 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-rcpptoml 0.2.2** does not exist (perhaps a typo or a missing channel);
├─ r-rdpack 2.6** is not installable because there are no viable options
│ ├─ r-rdpack 2.6 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-rdpack 2.6 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-rematch 2.0.0** is not installable because there are no viable options
│ ├─ r-rematch 2.0.0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-rematch 2.0.0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-reprex 2.1.0** is not installable because there are no viable options
│ ├─ r-reprex 2.1.0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-reprex 2.1.0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-rmarkdown 2.27** , which cannot be installed (as previously explained);
├─ r-rmpfr 0.9_5** is not installable because it requires
│ └─ m2w64-mpfr, which requires
│ └─ msys2-conda-epoch [20160418 |>=20160418 ], which conflicts with any installable versions previously reported;
├─ r-rprojroot 2.0.4** is not installable because there are no viable options
│ ├─ r-rprojroot 2.0.4 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-rprojroot 2.0.4 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-rstudioapi 0.16.0** is not installable because there are no viable options
│ ├─ r-rstudioapi 0.16.0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-rstudioapi 0.16.0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-rvest 1.0.4** is not installable because there are no viable options
│ ├─ r-rvest 1.0.4 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-rvest 1.0.4 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-sandwich 3.1_0** is not installable because there are no viable options
│ ├─ r-sandwich 3.1_0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-sandwich 3.1_0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-scales 1.3.0** is not installable because there are no viable options
│ ├─ r-scales 1.3.0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-scales 1.3.0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-stringr 1.5.1** is not installable because there are no viable options
│ ├─ r-stringr [1.5.0|1.5.1] would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-stringr [1.5.0|1.5.1] would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-tidyr 1.3.1** is not installable because it requires
│ └─ r-stringr >=1.5.0 but there are no viable options
│ ├─ r-stringr [1.5.0|1.5.1], which cannot be installed (as previously explained);
│ ├─ r-stringr [1.5.0|1.5.1], which cannot be installed (as previously explained);
│ └─ r-stringr 1.5.0 would require
│ └─ r-base >=4.1,<4.2.0a0 , which requires
│ └─ m2w64-zlib, which cannot be installed (as previously explained);
├─ r-tidyselect 1.2.1** is not installable because there are no viable options
│ ├─ r-tidyselect 1.2.1 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-tidyselect 1.2.1 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-tidytree 0.4.6** is not installable because there are no viable options
│ ├─ r-tidytree 0.4.6 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-tidytree 0.4.6 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-tidyverse 2.0.0** is not installable because there are no viable options
│ ├─ r-tidyverse 2.0.0 would require
│ │ └─ r-base >=4.1,<4.2.0a0 , which cannot be installed (as previously explained);
│ ├─ r-tidyverse 2.0.0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-tidyverse 2.0.0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-tinytex 0.51** is not installable because there are no viable options
│ ├─ r-tinytex 0.51 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-tinytex 0.51 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-vipor 0.4.7** is not installable because there are no viable options
│ ├─ r-vipor 0.4.7 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-vipor 0.4.7 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-viridis 0.6.5** is not installable because there are no viable options
│ ├─ r-viridis 0.6.5 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-viridis 0.6.5 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-viridislite 0.4.2** is not installable because there are no viable options
│ ├─ r-viridislite 0.4.2 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-viridislite 0.4.2 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-withr 3.0.0** is not installable because there are no viable options
│ ├─ r-withr 3.0.0 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-withr 3.0.0 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ r-xml2 1.3.6** does not exist (perhaps a typo or a missing channel);
├─ r-yulab.utils 0.1.4** is not installable because there are no viable options
│ ├─ r-yulab.utils 0.1.4 would require
│ │ └─ r-base >=4.2,<4.3.0a0 , which does not exist (perhaps a missing channel);
│ └─ r-yulab.utils 0.1.4 would require
│ └─ r-base >=4.3,<4.4.0a0 , which does not exist (perhaps a missing channel);
├─ raxml 8.2.13** does not exist (perhaps a typo or a missing channel);
├─ readline 8.2** does not exist (perhaps a typo or a missing channel);
├─ rescript 2024.5.0** does not exist (perhaps a typo or a missing channel);
├─ samtools 1.20** does not exist (perhaps a typo or a missing channel);
├─ scikit-bio 0.6.0** does not exist (perhaps a typo or a missing channel);
├─ sed 4.8** does not exist (perhaps a typo or a missing channel);
├─ sepp 4.4.0** does not exist (perhaps a typo or a missing channel);
├─ sortmerna 2.0** does not exist (perhaps a typo or a missing channel);
├─ tapi 1100.0.11** does not exist (perhaps a typo or a missing channel);
├─ unifrac-binaries 1.4** does not exist (perhaps a typo or a missing channel);
├─ unifrac 1.3** does not exist (perhaps a typo or a missing channel);
├─ vsearch 2.22.1** does not exist (perhaps a typo or a missing channel);
├─ wget 1.21.4** does not exist (perhaps a typo or a missing channel);
├─ xcb-util-image 0.4.0** does not exist (perhaps a typo or a missing channel);
├─ xcb-util-keysyms 0.4.0** does not exist (perhaps a typo or a missing channel);
├─ xcb-util-renderutil 0.3.9** does not exist (perhaps a typo or a missing channel);
├─ xcb-util-wm 0.4.1** does not exist (perhaps a typo or a missing channel);
├─ xcb-util 0.4.0** does not exist (perhaps a typo or a missing channel);
├─ xkeyboard-config 2.41** does not exist (perhaps a typo or a missing channel);
├─ xorg-libice 1.1.1** is requested and can be installed;
└─ xorg-libxt 1.3.0** is not installable because there are no viable options
├─ xorg-libxt 1.3.0 would require
│ └─ m2w64-gcc-libs-core, which requires
│ └─ msys2-conda-epoch [20160418 |>=20160418 ], which conflicts with any installable versions previously reporte;
└─ xorg-libxt 1.3.0 would require
└─ xorg-libice 1.0.* , which conflicts with any installable versions previously reported.
Can someone please help?

Welcome to the forums, Luis :qiime2:

Can you tell us more about your setup?

Like, is this WSL or are you installing this into the Windows terminal? :window:
Any other clues about this computer or your installation you can share with us?

1 Like

it is with wsl and typed it into the command prompt.

Which one?
The one with the penguin logo or the one that says Command Prompt?

the one that says Command Prompt

1 Like

Got it!

That's the Windows command prompt, and that won't work.

Click on the Start menu, search for 'wsl' and open it. That should work!

2 Likes

I tried it and it said "command not found" when I typed the code "conda env create -n qiime2-amplicon-2024.5 --file qiime2-amplicon-2024.5-py38-linux-conda.yml" from the qiime2 website.

Okay. This means conda is not installed.

Did you install miniconda into WSL?
(Installing miniconda into Windows will not help. WSL and Windows are mostly separate. Now that you know to use WSL and not the Windows terminal, make sure you did all the steps on the install page.)

Keep us posted! Now you are on the right track!

1 Like

Okay I think I did it correctly. What is the next step?

You can run qiime info to see what's been installed.

You could try running some real data from our tutorials.
https://docs.qiime2.org/2024.5/tutorials/

Idk, what's your biological question?

I tried following the step again in the QIIME2 website and I get the same error message. You said I need to make sure I did all the steps into WSL and not the Windows terminal correct?

Yes!

What did you run this time and what was the error?
(The more you share with us the more we can help!)

1 Like

it said conda command not found.

when i download conda should i download using the windows link or linux link

1 Like

Use the Linux link, and run this from within WSL.


I can see the problem; in our official docs we don't clearly say that we will be using Windows Subsystem for Linux because we don't support Windows natively.

So after going to the install instructions for miniconda, you select Windows (of course!) but it's a trap.

Because Qiime2 does not run on Windows.
Qiime2 does run on Windows Subsystem for Linux, which is Linux.
So only option that will work, counterintuitively, is Linux.

I'm sorry this process has taken a while. Now that you know to always use WSL, I think we are on the right track!

Thank you for your patience.

4 Likes

okay I followed all the steps you said and I get the message
Preparing transaction: done
Verifying transaction: done
Executing transaction: done

To activate this environment, use

$ conda activate qiime2-amplicon-2024.5

To deactivate an active environment, use

$ conda deactivate

I entered conda activate qiime2-amplicon-2024.5
Now it saids: (qiime2-amplicon-2024.5) root@Luis:~#

Hi @Luis1,

Looks like you have a qiime2 env installed! You can run qiime info, if you want a way to confirm!

Great, I tried it and it gave me
Installed plugins
alignment: 2024.5.0
composition: 2024.5.0
cutadapt: 2024.5.0
dada2: 2024.5.0
deblur: 2024.5.0
demux: 2024.5.0
diversity: 2024.5.1
diversity-lib: 2024.5.0
emperor: 2024.5.0
feature-classifier: 2024.5.0
feature-table: 2024.5.0
fragment-insertion: 2024.5.0
longitudinal: 2024.5.0
metadata: 2024.5.0
phylogeny: 2024.5.0
quality-control: 2024.5.0
quality-filter: 2024.5.0
rescript: 2024.5.1
sample-classifier: 2024.5.0
taxa: 2024.5.0
types: 2024.5.0
vsearch: 2024.5.0

2 Likes

Perfect! Looks like you are good to go!

Happy :qiime2: ing!

2 Likes