Installing qiime2-2018.6 segmentation fault during installation

I am quite new to qiime and command line in general, but was at the user workshop in Leipzig recently. Now, I wanted to install qiime2 on our linux cluster following your instructions on “Natively installing QIIME 2”. Getting miniconda worked, but after I activate the environment and type “qiime --help” to verify, I get:
“QIIME is caching your current deployment for improved performance. This may take a few moments and should only happen once per deployment.”
and then:
“Segmentation fault”
I already tried removing and reinstalling everything, but the problem remains. I read this post (Qiime2-2017.8 installation: segmentation fault), but I need more input how to solve my problem from that.
Can you help me?

Hi @corinnia,

Sorry for the very delayed response :frowning:

I think a few things might be happening:

  1. It’s the matplotlib/Qt5 issue from your linked post. We can probably test this by running inside your environment, the following command:

    python -c "import PyQt5"

    if you get a segfault, then we’ve found the issue!

  2. Your cluster has an absolutely ancient libc, there’s nothing we can actually do to fix this. Most software will run into this problem, and will require re-compilation on the host. Your sysadmin is likely aware if this is the case (since they will run into it often).

Let me know if either of these appears to be the case, otherwise, we’ll have to think of something else.

No problem, I got it installed and running in the meantime.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.