Installed CPLEX or Gurobi and micom

Hi

I tried to use micom

I installed CPEX and Girubi before but when I tried like below
micom grow --i-models /Users/admin/Desktop/16S\ pascal\ Loyer/qiime2_CCK/models.qza --i-medium /Users/admin/Downloads/western_diet_gut.qza --p-tradeoff 0.3 --p-threads 8 --o-results /Users/admin/Desktop/16S\ pascal\ Loyer/qiime2_CCK/growth.qza --verbose

An information is written on the screen
lugin error from micom:

All numerical optimizations failed. This indicates a problem with the solver or numerical instabilities. Check that you have CPLEX or Gurobi installed. You may also increase the abundance cutoff to create simpler models.

See above for debug info.

So I tried to reinstall culex and gurobi but there was the same problem…
Can you help me?
Thanks
Sandrine

Hi @sdavid,
Just pinging @cdiener and @seangibbons to make sure they see this.

I do
thanks
Sandrine

Sorry for the delay and that MICOM is giving you an error :cry:. It looks like the solver is installed correctly then but there may be a problem with the models and medium not lining up. Which model database did you use in qiime micom build, AGORA or carveME?

Also just to check how did you install Cplex and Gurobi? Thanks!