Installation issue: Solving environment: failed

I’m trying to “reinstall” qiime2 on a computer that I’ve updated to macOS Mojave. It had a qiime2 version 2018.6 that worked.

I keep getting this error: "conda env create -n qiime2-2019.1 --file qiime2-2019.1-py36-osx-conda.yml
Collecting package metadata: done
Solving environment: failed


  • libcxx=7.0.0"

I’ve tried removing miniconda from my computer and reinstalling it. But with no improvement.
Really grateful for any suggestions in a language understandable for someone with a lack of basic conda/terminal knowledge!



I am having the same problem with Mac OS Sierra. I updated to 2018.11 on one laptop this morning and was successful. By this afternoon, none of my other computers could be updated, and the error was the same as above.

I am having the same problem…

Hi @Anna, @tobinjan, and @RuneGronseth! Please try to give installation a try again. QIIME 2 uses the conda platform, and all of the software packages are hosted on --- sometimes that service has network issues, or packages get replaced/updated. I suspect you all got unlucky with timing --- I just installed a fresh deployment of 2019.1 on linux and everything worked as expected, so maybe is sorted out now. Thanks! :qiime2:

Oops, I spoke too soon. Looks like this package ( is only in the macos environments, and, it has been removed from (it is marked as “broken”). I think it makes sense for the QIIME 2 team to try and “redeploy” the environment files, now that this package is gone. Stay tuned… :tv:


Okay, we just release new OSX env files. Please delete the old ones, re-download, and try to install again. Please let us know if it works or not!


1 Like

It is flawless! Thank you very much!


Brilliant. Works now! Thanks!

1 Like

A post was split to a new topic: QIIME 2 2020.6 error solving env on WSL