Installation issue: NameError: name 'reload' is not defined

Hello Q2 Community -

I am installing the Q2 on my desktop and I am running in a issue.
The "conda" and "source" commands work fine before I create the qiime-2017.1 environment.
Once I do that, both commands give me the reload error as shown bellow.
The qiime seems to be installed, as I can get all the info when I type "qiime".

I must say it seems to be a problem on my machine, since I have installed and ran Q2 on my notebook. However, I need a more powerful computer to run all my samples.

Any input would be appreciated.
Thanks for your time!
R!

Hmm! Thanks for writing, @rgloreto — something certainly looks a little strange related to your base conda install.

What happens when you run

$ conda update conda

If that doesn’t do anything, you might want to try reinstalling conda, since it looks like something might have gone wrong at that step. Keep us posted! :t_rex:

@thermokarst
Thanks for the reply.

Any command, including the suggested one, gives me the same error. Again, it only happens after I create the qiime2 environment. Indeed, if only delete the qiime env, the conda commands works again. I have tried re-installing miniconda3 and it works ok until I install qiime2.

However, I managed to get around it by installing miniconda2 instead. I know it is not a solution for the error, but it allows me to continue my work.

Please let me know if you have other suggestions.

Thanks!
Best,
R!

1 Like

Hi @rgloreto! It sounds like you have a workaround (using Miniconda2) but we can continue to debug this if you’d like. We’ve had success using Miniconda3 and qiime2 – it’s actually the method we use more often than Miniconda2. I suspect it has to do with conflicting versions of Python on your system (could be related to your $PATH environment variable and how Miniconda is being installed). Let me know if you would like to continue to debugging this; I am happy to assist. Thanks!

@jairideout yes, please! I do want to debug this.
Many thanks!

Best,
R!

Great! Here are a series of commands that I’d like you to run in a few different contexts (see below for instructions on when to run them). Some of these commands are expected to fail; please run all of them anyways and send me the complete output.

Debug commands:

echo $PATH
echo $PYTHONPATH
echo $PYTHONHOME
ls -la $HOME/.local/lib
which python
python --version
alias python
which qiime
which conda
conda info -a
conda list

Contexts:

  1. Uninstall Miniconda2 and Miniconda3 completely so that conda does not exist on your system (see these instructions). Open a new terminal, run the debug commands above, and send the output.

  2. Reinstall Miniconda3 following these instructions. Open a new terminal, run conda clean -y --all, and then conda update conda. After that, run the debug commands above and send the output.

  3. Install QIIME 2 2017.11 following these instructions. Before activating the new qiime2 environment, run the debug commands above and send the output.

  4. Activate the qiime2-2017.11 conda environment, run the debug commands above, and send the output.

I know this is a lot of info to request – hopefully this will give me what I need to figure out what’s going on with your installation. Thanks!

@jairideout sorry for the delay.
I will get you all the info as soon I finish the analysis I am running now. I need to get this data to the collaborator. Once it is done - 1 or 2 days from now - I will uninstall the miniconda3 and follow the steps you describe as well as give you the output for those commands you listed. Many thanks for the help! I will get back to you soon.

Best,
R!

2 Likes

@jairideout My apologies for the delay.
I visiting my collaborator at the moment but I will get back to you next week.
Again, my apologies for delaying this. I do want to debug this.

Many thanks for your time.

Best,
R

2 Likes

I was fixed with the newer version of Q2.
Thanks for the assistance.

Sorry for the late reply.

Best,
R

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.